aboutsummaryrefslogtreecommitdiffstats
path: root/community/clsync/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-03 01:00:58 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-03 01:00:58 +0200
commit64a2d6243471cee6a4151768f8ef4ca556ba2402 (patch)
treed097604a14347806e08ff6529cb4687f139b175b /community/clsync/APKBUILD
parent8f9e0dc8f2e3b2ed519e3c41335f50d32240a751 (diff)
downloadaports-64a2d6243471cee6a4151768f8ef4ca556ba2402.tar.bz2
aports-64a2d6243471cee6a4151768f8ef4ca556ba2402.tar.xz
community/clsync: move from testing
Diffstat (limited to 'community/clsync/APKBUILD')
-rw-r--r--community/clsync/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/community/clsync/APKBUILD b/community/clsync/APKBUILD
new file mode 100644
index 0000000000..0cfa0f3521
--- /dev/null
+++ b/community/clsync/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=clsync
+pkgver=0.4.2
+pkgrel=0
+pkgdesc="File live sync daemon based on inotify"
+url="https://github.com/xaionaro/clsync"
+arch="x86 x86_64"
+license="GPLv3+"
+depends=""
+depends_dev="glib-dev fts-dev libcap-dev libexecinfo-dev linux-headers musl-dev"
+makedepends="$depends_dev autoconf automake file libtool"
+subpackages="$pkgname-doc $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/xaionaro/$pkgname/archive/v$pkgver.tar.gz
+ musl-fix.patch
+ pthread_setname_np.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check" # upstream does not provide tests
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ autoreconf -i
+}
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ CFLAGS="$CFLAGS -lfts -lexecinfo" \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-capabilities \
+ --enable-seccomp \
+ --disable-debug
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install
+
+ # https://github.com/xaionaro/clsync/issues/150
+ rm "$pkgdir"/usr/bin/gencompilerflags
+}
+
+sha512sums="d14a2efc4bf58d9d5c7a3fe5634cacdd182cd7cd814b0e9ebd99024a7282b056d1f7ceeec6903666391c3572d599a18e205af818b098ed7768d5c0e0f4cd1200 clsync-0.4.2.tar.gz
+98e81408911731f6e203368094ea0e9eda312648eef8c5beec98b13c6ee43bccee59f0777805bea4d26cbe4e964d2ff95fe863be5be7750b50358d213f106542 musl-fix.patch
+da65cfb7182fa1509c77d7da43132c1f8b4911acb819d90aaab88c78d35167c85c0f23259bb78983fdab8217c43ba93b6b21267ab96c7fdf4723878a800fe414 pthread_setname_np.patch"