aboutsummaryrefslogtreecommitdiffstats
path: root/community/clsync
diff options
context:
space:
mode:
authorossdev <ossdev@puresoftware.com>2019-07-03 12:17:51 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-07-06 04:33:08 -0300
commit19cd0394d3ed89d57dd6b1a950966ca86246e464 (patch)
tree2117626671f397269e5782bdb40d112564b1a4ed /community/clsync
parentcce20652c6fc3a5e570e39d6b170c4bf11861be8 (diff)
downloadaports-19cd0394d3ed89d57dd6b1a950966ca86246e464.tar.bz2
aports-19cd0394d3ed89d57dd6b1a950966ca86246e464.tar.xz
community/clsync: Provided support for aarch64 Architectural check
Signed-off-by: ossdev <ossdev@puresoftware.com>
Diffstat (limited to 'community/clsync')
-rw-r--r--community/clsync/APKBUILD32
1 files changed, 20 insertions, 12 deletions
diff --git a/community/clsync/APKBUILD b/community/clsync/APKBUILD
index e06d4e0fc9..4d9d3cbe37 100644
--- a/community/clsync/APKBUILD
+++ b/community/clsync/APKBUILD
@@ -5,7 +5,7 @@ pkgver=0.4.2
pkgrel=1
pkgdesc="File live sync daemon based on inotify"
url="https://github.com/xaionaro/clsync"
-arch="x86 x86_64"
+arch="x86 x86_64 aarch64"
license="GPL-3.0-or-later"
depends=""
depends_dev="glib-dev fts-dev libcap-dev libexecinfo-dev linux-headers musl-dev"
@@ -15,6 +15,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/xaionaro/$pkgname/archive/v$
musl-fix.patch"
builddir="$srcdir/$pkgname-$pkgver"
options="!check" # upstream does not provide tests
+seccomp=""
prepare() {
default_prepare
@@ -26,17 +27,24 @@ prepare() {
build() {
cd "$builddir"
- ./configure \
- CFLAGS="$CFLAGS -lfts -lexecinfo" \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --enable-capabilities \
- --enable-seccomp \
- --disable-debug
+ case "$CARCH" in
+ aarch64)
+ seccomp="disable-seccomp" ;;
+ *)
+ seccomp="enable-seccomp" ;;
+ esac
+ ./configure \
+ CFLAGS="$CFLAGS -lfts -lexecinfo" \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-capabilities \
+ --$seccomp \
+ --disable-debug
+
make
}