aboutsummaryrefslogtreecommitdiffstats
path: root/community/coretime
diff options
context:
space:
mode:
authorrahmanshaber <rahmanshaber@yahoo.com>2019-09-24 13:10:16 +0800
committerRasmus Thomsen <oss@cogitri.dev>2019-10-06 11:41:13 +0200
commit8ab45faea71e393e4fae5d3385f0d06b7b5540c3 (patch)
tree7e3a10c468ff5b0eb2a33d05159890d0721c0ca3 /community/coretime
parent694a7eebf3799d77953af2b79b6649e32c9aa828 (diff)
downloadaports-8ab45faea71e393e4fae5d3385f0d06b7b5540c3.tar.bz2
aports-8ab45faea71e393e4fae5d3385f0d06b7b5540c3.tar.xz
community/coretime: move from testing
Diffstat (limited to 'community/coretime')
-rw-r--r--community/coretime/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/community/coretime/APKBUILD b/community/coretime/APKBUILD
new file mode 100644
index 0000000000..2c0e382633
--- /dev/null
+++ b/community/coretime/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: rahmanshaber <rahmanshaber@yahoo.com>
+# Maintainer: rahmanshaber <rahmanshaber@yahoo.com>
+pkgname=coretime
+pkgver=2.7.0
+pkgrel=0
+pkgdesc="A time related task manager from the CoreApps family."
+arch="all"
+url="https://gitlab.com/cubocore"
+license="GPL-3.0-or-later"
+depends="qt5-qtsvg"
+makedepends="qt5-qtbase-dev libcprime-dev qt5-qtmultimedia-dev"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-v$pkgver"
+options="!check"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ INSTALL_ROOT="$pkgdir" make install
+}
+sha512sums="f149ab450e7e85c121caf9197322eed1acd906aa5ef72baf057bd8c3fce0bf2eb2cb13a6e445ba1f9c3322a6336d0e6512f756d0ba0d77d3a72b7b1985115d6b coretime-2.7.0.tar.gz"