aboutsummaryrefslogtreecommitdiffstats
path: root/community/cppcheck
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-23 12:46:51 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-23 18:25:10 -0300
commit54cf11bd641160b33fc453c8a7f098099d2c24bc (patch)
tree55bca481727a31eaf211656a1fda50430b66b120 /community/cppcheck
parent0e89651be5831c87f935e3dd3732ba1e7488550d (diff)
downloadaports-54cf11bd641160b33fc453c8a7f098099d2c24bc.tar.bz2
aports-54cf11bd641160b33fc453c8a7f098099d2c24bc.tar.xz
community/cppcheck: drop python2
Diffstat (limited to 'community/cppcheck')
-rw-r--r--community/cppcheck/APKBUILD14
-rw-r--r--community/cppcheck/python3-htmlreport.patch28
2 files changed, 38 insertions, 4 deletions
diff --git a/community/cppcheck/APKBUILD b/community/cppcheck/APKBUILD
index 66ffbe4a5d..2370cd8229 100644
--- a/community/cppcheck/APKBUILD
+++ b/community/cppcheck/APKBUILD
@@ -2,19 +2,24 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=cppcheck
pkgver=1.89
-pkgrel=0
+pkgrel=1
pkgdesc="Static analysis tool for C/C++ code"
url="http://cppcheck.sourceforge.net"
arch="all"
license="GPL-3.0-or-later"
-makedepends="docbook-xsl pcre-dev python qt5-qttools-dev"
+makedepends="docbook-xsl pcre-dev python3 qt5-qttools-dev"
subpackages="$pkgname-doc $pkgname-htmlreport::noarch $pkgname-gui"
source="$pkgname-$pkgver.tar.gz::https://github.com/danmar/cppcheck/archive/$pkgver.tar.gz
set_datadir.patch
disable-findFunction19-test.patch
+ python3-htmlreport.patch
"
build() {
+ # HACK get python to mean what we want
+ ln -s /usr/bin/python3 python
+ export PATH="$(pwd):$PATH"
+
make DB2MAN=/usr/share/xml/docbook/xsl-stylesheets-*/manpages/docbook.xsl man
cd gui
@@ -34,7 +39,7 @@ package() {
htmlreport() {
pkgdesc="Utility to generate a html report of a XML file produced by cppcheck"
- depends="$pkgname py-pygments"
+ depends="$pkgname python3 py3-pygments"
cd "$builddir"
mkdir -p "$subpkgdir"/usr/bin
@@ -55,4 +60,5 @@ gui() {
sha512sums="0e8f7ae6fe70261f69954ec830c20faff37126ec41a7fdc59ce91db99313a1c99e1850656efeb7182a37fb78fbf8402b71d72a11d6189a5bede2819bdde69b9b cppcheck-1.89.tar.gz
013e3d1bb49602ac0bf39335d5b4df001aa98e1ad9689207063460edc30a4cd7b67f5e880bd0bcae0c03e5724a8bdd0cb5c8cafcb89a815dab24b2ead2923f36 set_datadir.patch
-dd118f930aa509ee3d8b39d920f5de38b425657cc8a44520bb13b8f744aa4f2fe2bcd61141dbe1730f3202b70aecd3ef2531a04b8ebccdc5475cbe1a4dda38ab disable-findFunction19-test.patch"
+dd118f930aa509ee3d8b39d920f5de38b425657cc8a44520bb13b8f744aa4f2fe2bcd61141dbe1730f3202b70aecd3ef2531a04b8ebccdc5475cbe1a4dda38ab disable-findFunction19-test.patch
+346c5b41af809dfbff00b7ce66f8abc0e038d6272cf08bbefc4bfc6eaf32940815faca376609165de85072761271521c2a7a56aa7c59e88f65f7d9514b35aaff python3-htmlreport.patch"
diff --git a/community/cppcheck/python3-htmlreport.patch b/community/cppcheck/python3-htmlreport.patch
new file mode 100644
index 0000000000..eb397517a9
--- /dev/null
+++ b/community/cppcheck/python3-htmlreport.patch
@@ -0,0 +1,28 @@
+diff -up cppcheck-1.88/htmlreport/cppcheck-htmlreport.python3 cppcheck-1.88/htmlreport/cppcheck-htmlreport
+--- cppcheck-1.88/htmlreport/cppcheck-htmlreport.python3 2019-06-29 09:51:25.000000000 +0200
++++ cppcheck-1.88/htmlreport/cppcheck-htmlreport 2019-08-14 11:02:23.791627296 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/python3
+
+ from __future__ import unicode_literals
+
+diff -up cppcheck-1.88/htmlreport/setup.py.python3 cppcheck-1.88/htmlreport/setup.py
+--- cppcheck-1.88/htmlreport/setup.py.python3 2019-06-29 09:51:25.000000000 +0200
++++ cppcheck-1.88/htmlreport/setup.py 2019-08-14 11:02:28.570423533 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/python3
+
+ from setuptools import setup
+
+diff -up cppcheck-1.88/htmlreport/test_htmlreport.py.python3 cppcheck-1.88/htmlreport/test_htmlreport.py
+--- cppcheck-1.88/htmlreport/test_htmlreport.py.python3 2019-06-29 09:51:25.000000000 +0200
++++ cppcheck-1.88/htmlreport/test_htmlreport.py 2019-08-14 11:02:20.296776345 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/python3
+ """Test cppcheck-htmlreport."""
+
+ import os
+