aboutsummaryrefslogtreecommitdiffstats
path: root/community/deadbeef
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2016-08-03 13:03:06 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2016-08-03 13:03:06 +0200
commit089d2a8d46a043f78dabbdaab615dbd98b7f1650 (patch)
tree66ec9013bd873229bdb56fee21f4f43b6ddf4ded /community/deadbeef
parenteaea7f3d3e99f05562f2d8b93101ee09e63d35cb (diff)
downloadaports-089d2a8d46a043f78dabbdaab615dbd98b7f1650.tar.bz2
aports-089d2a8d46a043f78dabbdaab615dbd98b7f1650.tar.xz
community/deadbeef: try to fix similar issue in sid plugin
Diffstat (limited to 'community/deadbeef')
-rw-r--r--community/deadbeef/APKBUILD6
-rw-r--r--community/deadbeef/arm-buildfix.patch26
2 files changed, 29 insertions, 3 deletions
diff --git a/community/deadbeef/APKBUILD b/community/deadbeef/APKBUILD
index e387ef153e..6fa854eb39 100644
--- a/community/deadbeef/APKBUILD
+++ b/community/deadbeef/APKBUILD
@@ -35,8 +35,8 @@ package() {
}
md5sums="f8f5353e7c201fce316f8b082ab408bb deadbeef-0.7.2.tar.bz2
-50c31221a464683f885dc34850b9c5b0 arm-buildfix.patch"
+825397a941417e31cb28e6fc9202c3cf arm-buildfix.patch"
sha256sums="8a63abdf00c2f37c33e018ae0b39d391873e037434074b84bb47381bf283c884 deadbeef-0.7.2.tar.bz2
-4e9802a1dc7b735878fc6b59433da29a20759f4227f902ee08a800a0903a68ff arm-buildfix.patch"
+87b671ce5a8c2d0ef98c270ae1005648a4ae3e1298b408eb937974664def6a27 arm-buildfix.patch"
sha512sums="9ea61a3820d9d57f038b80652ce63bd87e6781259c0f58a93b70607b02e71debbf5598f4a06d607d3840a804c3b7fc5039a4c4b0a8bb01e8e5107bba3f0bd980 deadbeef-0.7.2.tar.bz2
-4ab094475d5caebc65235e54b30fa803aab7465ded41ce5dd359921778baf1b187777af021eb34a82b6551f930e2061e0535556b458dbc95050d9ea30aaccc89 arm-buildfix.patch"
+57e25e3478b5516f0ebc34fa561c619bdca4cdf7e9f6dc1d81317c972b10bd073a4a761dfc2327047fd56433e79ff57bf501c9cfe77079c450b46f5a0315555b arm-buildfix.patch"
diff --git a/community/deadbeef/arm-buildfix.patch b/community/deadbeef/arm-buildfix.patch
index 4404891948..5776b9225a 100644
--- a/community/deadbeef/arm-buildfix.patch
+++ b/community/deadbeef/arm-buildfix.patch
@@ -24,3 +24,29 @@ index cf58c44..a00404c 100644
static const unsigned short notetable[12];
static const unsigned char vibratotab[32];
+diff --git a/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.cpp b/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.cpp
+index 29b5c90..55dd167 100644
+--- a/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.cpp
++++ b/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.cpp
+@@ -81,7 +81,7 @@ const int8_t XSID::sampleConvertTable[16] =
+ '\x08', '\x19', '\x2a', '\x3b', '\x4c', '\x5d', '\x6e', '\x7f'
+ };
+ */
+-const int8_t XSID::sampleConvertTable[16] =
++const uint8_t XSID::sampleConvertTable[16] =
+ {
+ '\x80', '\x94', '\xa9', '\xbc', '\xce', '\xe1', '\xf2', '\x03',
+ '\x1b', '\x2a', '\x3b', '\x49', '\x58', '\x66', '\x73', '\x7f'
+diff --git a/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.h b/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.h
+index 98171d7..9dee5e3 100644
+--- a/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.h
++++ b/plugins/sid/sidplay-libs/libsidplay/src/xsid/xsid.h
+@@ -234,7 +234,7 @@ private:
+ uint8_t sidData0x18;
+ bool _sidSamples;
+ int8_t sampleOffset;
+- static const int8_t sampleConvertTable[16];
++ static const uint8_t sampleConvertTable[16];
+ bool wasRunning;
+
+ private: