aboutsummaryrefslogtreecommitdiffstats
path: root/community/deadbeef
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-04 13:17:45 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-11-04 13:17:45 +0000
commita364084d29bd512b7e4390e8ff2720388cdb47a9 (patch)
tree617b9b11c7c8eb211f464c775539d9912edcc6e6 /community/deadbeef
parentc1e85365cd69061d29cb21db5f677cb580469403 (diff)
downloadaports-a364084d29bd512b7e4390e8ff2720388cdb47a9.tar.bz2
aports-a364084d29bd512b7e4390e8ff2720388cdb47a9.tar.xz
community/deadbeef: fix build with gcc6
use std gnu++98 to avoid narrowing errors
Diffstat (limited to 'community/deadbeef')
-rw-r--r--community/deadbeef/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/deadbeef/APKBUILD b/community/deadbeef/APKBUILD
index 6fa854eb39..f3b6c9a2b3 100644
--- a/community/deadbeef/APKBUILD
+++ b/community/deadbeef/APKBUILD
@@ -4,7 +4,7 @@
pkgname=deadbeef
pkgver=0.7.2
_ver=${pkgver/_rc/-rc}
-pkgrel=0
+pkgrel=1
pkgdesc="fairly capable playlist-oriented audio player"
url="http://deadbeef.sourceforge.net/"
arch="all"
@@ -22,6 +22,7 @@ builddir="${srcdir}/${pkgname}-$_ver"
build() {
cd "$builddir"
+ CXXFLAGS="$CXXFLAGS -std=gnu++98" \
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \