aboutsummaryrefslogtreecommitdiffstats
path: root/community/desktop-file-utils/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 19:19:14 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-08 23:57:39 +0000
commitc64f864e7fc7d3f4fa2d2e4622aeb31552233a73 (patch)
tree4beb2457764a34ebc0d92dcfb5e28e4091548cbe /community/desktop-file-utils/APKBUILD
parent6a78b97ad157561e5aec84344f7347fcfc466335 (diff)
downloadaports-c64f864e7fc7d3f4fa2d2e4622aeb31552233a73.tar.bz2
aports-c64f864e7fc7d3f4fa2d2e4622aeb31552233a73.tar.xz
community/desktop-file-utils: move from main
Diffstat (limited to 'community/desktop-file-utils/APKBUILD')
-rw-r--r--community/desktop-file-utils/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/community/desktop-file-utils/APKBUILD b/community/desktop-file-utils/APKBUILD
new file mode 100644
index 0000000000..c049a8edd8
--- /dev/null
+++ b/community/desktop-file-utils/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=desktop-file-utils
+pkgver=0.24
+pkgrel=0
+pkgdesc="Command line utilities for working with desktop entries"
+url="http://www.freedesktop.org/wiki/Software/desktop-file-utils"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="glib-dev gettext-dev"
+subpackages="$pkgname-doc"
+triggers="$pkgname.trigger=/usr/share/applications"
+source="https://www.freedesktop.org/software/desktop-file-utils/releases/desktop-file-utils-$pkgver.tar.xz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b19d700d4403c8757c62e49bb7650e0138a85e799f79de07b0d0099a52398a3ead90c8125ccc883df6e2a3f8f5f97696009ebb7452dc7acc25afeef20e06fde0 desktop-file-utils-0.24.tar.xz"