aboutsummaryrefslogtreecommitdiffstats
path: root/community/dhcp-helper/compile-only-once.patch
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-10-08 21:35:00 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2018-10-08 21:35:42 -0500
commitd8c154d8781368526e412df2360801e0a451c109 (patch)
tree54b4644ae792791d57cc6f71d17b778026b9ba4d /community/dhcp-helper/compile-only-once.patch
parent4a37223c57e2c0028b0b907e15738184859ef29a (diff)
downloadaports-d8c154d8781368526e412df2360801e0a451c109.tar.bz2
aports-d8c154d8781368526e412df2360801e0a451c109.tar.xz
community/dhcp-helper: new aport
used in production for a few months, just never got around to committing it
Diffstat (limited to 'community/dhcp-helper/compile-only-once.patch')
-rw-r--r--community/dhcp-helper/compile-only-once.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/dhcp-helper/compile-only-once.patch b/community/dhcp-helper/compile-only-once.patch
new file mode 100644
index 0000000000..c35c6746e6
--- /dev/null
+++ b/community/dhcp-helper/compile-only-once.patch
@@ -0,0 +1,13 @@
+--- dhcp-helper-1.2.orig/Makefile
++++ dhcp-helper-1.2/Makefile
+@@ -5,7 +5,9 @@
+ CFLAGS?= -O2
+ version= $(shell ./get-version)
+
+-all: dhcp-helper.c
++all: dhcp-helper
++
++dhcp-helper: dhcp-helper.c
+ $(CC) $(CFLAGS) $(RPM_OPT_FLAGS) -DVERSION=\"$(version)\" -Wall -W dhcp-helper.c -o dhcp-helper
+
+ clean: