aboutsummaryrefslogtreecommitdiffstats
path: root/community/discount
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-01 04:46:23 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-01 06:55:32 -0300
commitf066b05f286653d2cf9a2cd2d8455e91bd204ad6 (patch)
tree8ea24741d9f83bc024884792e322f3c8972437b2 /community/discount
parent9db5a6fe82b74c879c6f20e8cf93e78e11b75dbe (diff)
downloadaports-f066b05f286653d2cf9a2cd2d8455e91bd204ad6.tar.bz2
aports-f066b05f286653d2cf9a2cd2d8455e91bd204ad6.tar.xz
community/discount: upgrade to 2.2.6
Diffstat (limited to 'community/discount')
-rw-r--r--community/discount/APKBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/community/discount/APKBUILD b/community/discount/APKBUILD
index 4fb732b8e2..1f7cc92b03 100644
--- a/community/discount/APKBUILD
+++ b/community/discount/APKBUILD
@@ -1,23 +1,20 @@
# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=discount
-pkgver=2.2.4
+pkgver=2.2.6
pkgrel=0
pkgdesc="A Markdown to HTML translator written in C"
url="http://www.pell.portland.or.us/~orc/Code/discount/"
arch="all"
-license="BSD"
+license="BSD-3-Clause"
depends="!markdown"
-makedepends=""
checkdepends="diffutils"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="http://www.pell.portland.or.us/~orc/Code/discount/$pkgname-$pkgver.tar.bz2
+source="$pkgname-$pkgver.tar.gz::https://github.com/Orc/discount/archive/v$pkgver.tar.gz
configure.inc.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
./configure.sh \
--prefix=/usr \
--mandir=/usr/share/man \
@@ -25,17 +22,15 @@ build() {
--with-fenced-code \
--pkg-config \
--shared
- make
+ make -j1
}
check() {
msg "Running testsuites..."
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make PREFIX=/usr DESTDIR="$pkgdir" install.everything
local bin; for bin in theme makepage mkd2html; do
mv "$pkgdir"/usr/bin/$bin \
@@ -45,5 +40,5 @@ package() {
done
}
-sha512sums="0650e0ce3f6948e3a30fdaa1a810e895f64621c55df46c7a5ed8755e65c1b718b7a1d1a1bfe0a87a3a59fbb13fca8907718f1aa095125a4b6e152602b8e490cf discount-2.2.4.tar.bz2
+sha512sums="4c5956dea78aacd3a105ddac13f1671d811a5b2b04990cdf8485c36190c8872c4b1b9432a7236f669c34b07564ecd0096632dced54d67de9eaf4f23641417ecc discount-2.2.6.tar.gz
6935a52d3fa1ee70e21cf6290bd83e045e8da349ef48ab7241c4eb075caded11945c9d1eabc7e9cdf549a4101daf81e10675464b84876838da669d2086f1de43 configure.inc.patch"