aboutsummaryrefslogtreecommitdiffstats
path: root/community/discount
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-06 14:36:20 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2017-11-06 14:39:15 +0000
commite49b9f705d418fb100cbe7a2346d02c6c98ff28e (patch)
tree409a0e021ca9590e452510c36d57c6a7c448d8e7 /community/discount
parent31d9cf5a974e10b36ce1b2ed16d1e7d28b9eeb52 (diff)
downloadaports-e49b9f705d418fb100cbe7a2346d02c6c98ff28e.tar.bz2
aports-e49b9f705d418fb100cbe7a2346d02c6c98ff28e.tar.xz
testing/discount: moved from testing and take maintainership
Diffstat (limited to 'community/discount')
-rw-r--r--community/discount/APKBUILD34
-rw-r--r--community/discount/configure.inc.patch19
2 files changed, 53 insertions, 0 deletions
diff --git a/community/discount/APKBUILD b/community/discount/APKBUILD
new file mode 100644
index 0000000000..b9bd1a3555
--- /dev/null
+++ b/community/discount/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
+pkgname=discount
+pkgver=2.2.2
+pkgrel=0
+pkgdesc="A Markdown to HTML translator written in C"
+url="http://www.pell.portland.or.us/~orc/Code/discount/"
+arch="all"
+license="BSD"
+depends="!markdown"
+makedepends=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.pell.portland.or.us/~orc/Code/discount/$pkgname-$pkgver.tar.bz2
+ configure.inc.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure.sh \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-all-features \
+ --with-fenced-code \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install install.man || return 1
+}
+
+sha512sums="67d882c0a334592230332815c543458b3c916a950bf7983f8a468fbc9f61154b4023d4bf451b76639fcb3a076506b48118f192a8e21f2535b3f49c7f081bbdf3 discount-2.2.2.tar.bz2
+d243f0b5e01cd91376fa94960e9abcdbf24d3579f7d4b5220262e867adefdc5e9ed850fe0228cc290ed605f4b42c50a5ce1ac3fb61ff191a24dc2349d16b2ff2 configure.inc.patch"
diff --git a/community/discount/configure.inc.patch b/community/discount/configure.inc.patch
new file mode 100644
index 0000000000..b665754150
--- /dev/null
+++ b/community/discount/configure.inc.patch
@@ -0,0 +1,19 @@
+--- a/configure.inc
++++ b/configure.inc
+@@ -1332,7 +1332,6 @@
+ $PROG_LN_S -f \$FULLNAME \$1/\$LIBNAME.\$MAJOR
+ $PROG_LN_S -f \$FULLNAME \$1/\$LIBNAME
+ EOF
+- test "$LDCONFIG" && echo ' '$LDCONFIG '"$1"' >> librarian.sh
+ cat >> librarian.sh << EOF
+ ;;
+ esac
+@@ -1420,7 +1419,7 @@
+
+ AC_SUB 'INSTALL' "$PROG_INSTALL"
+ AC_SUB 'INSTALL_PROGRAM' "$PROG_INSTALL -s -m 755"
+- AC_SUB 'INSTALL_DATA' "$PROG_INSTALL -m 444"
++ AC_SUB 'INSTALL_DATA' "$PROG_INSTALL -m 644"
+
+ # finally build a little directory installer
+ # if mkdir -p works, use that, otherwise use install -d,