aboutsummaryrefslogtreecommitdiffstats
path: root/community/dmenu
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 18:51:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-25 08:25:49 -0300
commit694681274fd0180876319c263a8de6aeffe2578c (patch)
tree297f330b730528aebad676646e57b30b9353a0dd /community/dmenu
parentaf3255c60801f09d9de8396c38be2b9db0a7a0a2 (diff)
downloadaports-694681274fd0180876319c263a8de6aeffe2578c.tar.bz2
aports-694681274fd0180876319c263a8de6aeffe2578c.tar.xz
community/dmenu: move from main
Diffstat (limited to 'community/dmenu')
-rw-r--r--community/dmenu/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/community/dmenu/APKBUILD b/community/dmenu/APKBUILD
new file mode 100644
index 0000000000..2eb36bdd39
--- /dev/null
+++ b/community/dmenu/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Eivind Uggedal <eu@eju.no>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=dmenu
+pkgver=4.9
+pkgrel=0
+pkgdesc="Dynamic menu for X"
+url="https://tools.suckless.org/dmenu/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="libx11-dev libxinerama-dev libxft-dev"
+install=""
+options="!check"
+subpackages="$pkgname-doc"
+source="https://dl.suckless.org/tools/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ default_prepare
+ sed -i -e '/CFLAGS/{s/-Os//;s/=/+=/}' \
+ -e '/LDFLAGS/{s/=/+=/}' \
+ "$builddir"/config.mk
+}
+
+build() {
+ make X11INC=/usr/include/X11 \
+ X11LIB=/usr/lib/X11 \
+ FREETYPEINC=/usr/include/freetype2 \
+ -C "$builddir"
+}
+
+package() {
+ make DESTDIR=$pkgdir PREFIX=/usr \
+ -C "$builddir" install
+}
+
+sha512sums="c2779209fe012de8ca1cdd72923da6d594f4a8368c85c3c0e0afd4ae489a95fe0e6f05a947d115b6b389aa7170ab14c2c645a2031353b0a08f38327ab461fe65 dmenu-4.9.tar.gz"