aboutsummaryrefslogtreecommitdiffstats
path: root/community/dnscrypt-proxy
diff options
context:
space:
mode:
authorIan Bashford <ianbashford@gmail.com>2019-12-03 17:37:33 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-12-03 19:01:56 +0100
commit0a95cf27b24bcd416522236fde74796ce05af78f (patch)
tree7c3c9e11b0408e8fcf4bfd5864dfc29875ca5863 /community/dnscrypt-proxy
parentaf2701a7c81348c0242c55d4ba392a7df42ce6a7 (diff)
downloadaports-0a95cf27b24bcd416522236fde74796ce05af78f.tar.bz2
aports-0a95cf27b24bcd416522236fde74796ce05af78f.tar.xz
community/dnscrypt-proxy: upgrade to 2.0.34
add functionality for local DOH server
Diffstat (limited to 'community/dnscrypt-proxy')
-rw-r--r--community/dnscrypt-proxy/APKBUILD8
-rw-r--r--community/dnscrypt-proxy/config-full-paths.patch35
2 files changed, 38 insertions, 5 deletions
diff --git a/community/dnscrypt-proxy/APKBUILD b/community/dnscrypt-proxy/APKBUILD
index 2354187860..2a7168b7a4 100644
--- a/community/dnscrypt-proxy/APKBUILD
+++ b/community/dnscrypt-proxy/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Ian Bashford <ianbashford@gmail.com>
# Maintainer: Ian Bashford <ianbashford@gmail.com>
pkgname=dnscrypt-proxy
-pkgver=2.0.33
-pkgrel=1
+pkgver=2.0.34
+pkgrel=0
pkgdesc="A tool for securing communications between a client and a DNS resolver"
url="https://dnscrypt.info"
arch="all"
@@ -52,8 +52,8 @@ setup() {
install -m755 -D "$srcdir"/$pkgname.setup "$subpkgdir"/usr/sbin/setup-dnscrypt
}
-sha512sums="5c6eb655aa70457889253cbf630e7e37011a461a7f181f0a667694d53146ad9dee88bbbf80c7db3187bba0054af2a63b7b5be1a229800b2566a9758e9d047429 dnscrypt-proxy-2.0.33.tar.gz
+sha512sums="b48bbedbd5fea5514669ff5593ecd0aee083979c3030fe775558441ee2c398206eba786b9497022c3fab08fe7ee49dcc5205303629834f8fe65d7246e3352381 dnscrypt-proxy-2.0.34.tar.gz
e0a72d39d47dc24b889d08beedbd9fdf21615f42fbab79980debdfd2c3feaa83dc3f776351f7dd13533cc85905ce4e01812e4ff8a80a9ccc0b21e9db7d6cb232 dnscrypt-proxy.initd
c001ae39da1b2db71764cab568f9ed18e4de0cea3d1a4e7bd6dd01a5668b81a888ea9eef99de6beac08857ad7f8eb1a32d730e946ac3563e4dcfa27147e35052 dnscrypt-proxy.confd
66dd43d84117a0151ae41f34d82b716760382a5a491424bf6418228ffd21f0dfbc88e34cc5074e11f97f006335d97b85367bb9ab1d96747a48e893c022ad52d0 dnscrypt-proxy.setup
-1d9cf44ec92dfe1efb092e2b214730932b3f5b9c75907c37429e3eadfdc77e1d9aa54480ed856d1c9e08c9a5c9c5c91d3c110e0307963745d43c6c0f65b2b6c9 config-full-paths.patch"
+c1b0a2a197b238c40371bbcab6fd32caea4b79b236a16a93a3da695043c7584304488194042027f97da05ca0a80df193f4849aad71a9917f92bbce843f9af33c config-full-paths.patch"
diff --git a/community/dnscrypt-proxy/config-full-paths.patch b/community/dnscrypt-proxy/config-full-paths.patch
index b2149acfde..19ab63da5c 100644
--- a/community/dnscrypt-proxy/config-full-paths.patch
+++ b/community/dnscrypt-proxy/config-full-paths.patch
@@ -37,8 +37,10 @@ index 0000000..736ec29
+
+
+## List of local addresses and ports to listen to. Can be IPv4 and/or IPv6.
++## Example with both IPv4 and IPv6:
++## listen_addresses = ['127.0.0.1:53', '[::1]:53']
+
-+listen_addresses = ['127.0.0.1:53', '[::1]:53']
++listen_addresses = ['127.0.0.1:53']
+
+
+## Maximum number of simultaneous client connections to accept
@@ -344,6 +346,37 @@ index 0000000..736ec29
+
+
+
++##################################
++# Local DoH server #
++##################################
++
++[local_doh]
++
++## dnscrypt-proxy can act as a local DoH server. By doing so, web browsers
++## requiring a direct connection to a DoH server in order to enable some
++## features will enable these, without bypassing your DNS proxy..
++
++## Addresses that the local DoH server should listen to
++
++# listen_addresses = ['127.0.0.1:3000']
++
++
++## Path of the DoH URL. This is not a file, but the part after the hostname
++## in the URL. By convention, `/dns-query` is frequently chosen.
++## For each `listen_address` the complete URL to access the server will be:
++## `https://<listen_address><path>` (ex: `https://127.0.0.1/dns-query`)
++
++# path = "/dns-query"
++
++
++## Certificate file and key - Note that the certificate has to be trusted.
++## See the Wiki for more information.
++
++# cert_file = "localhost.pem"
++# cert_key_file = "localhost.pem"
++
++
++
+###############################
+# Query logging #
+###############################