aboutsummaryrefslogtreecommitdiffstats
path: root/community/docker
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-26 13:08:50 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-05 19:09:36 +0000
commit606c7696b894895aa52e0f4c27a7c159caaa1c76 (patch)
tree16865ae9447edda68ae6cdc7465bece1c7fe5a71 /community/docker
parent8a8cf569dbe8e8e7aaf06de4e8cdf88a9709eafd (diff)
downloadaports-606c7696b894895aa52e0f4c27a7c159caaa1c76.tar.bz2
aports-606c7696b894895aa52e0f4c27a7c159caaa1c76.tar.xz
community/docker: don't install docker-fish-completion on newer fish
The newer fish has docker completion upstream, installing docker-fish-completion will just lead to a file conflict
Diffstat (limited to 'community/docker')
-rw-r--r--community/docker/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/docker/APKBUILD b/community/docker/APKBUILD
index 8b7b32a9a5..5f1af328f5 100644
--- a/community/docker/APKBUILD
+++ b/community/docker/APKBUILD
@@ -5,7 +5,7 @@ pkgname=docker
pkgver=18.09.5
_gitcommit=e8ff056dbcfadaeca12a5f508b0cec281126c01d # https://github.com/docker/docker-ce/commits/v$pkgver
_ver=${pkgver/_/-}-ce
-pkgrel=0
+pkgrel=1
pkgdesc="Pack, ship and run any application as a lightweight container"
url="http://www.docker.io/"
arch="all"
@@ -160,7 +160,7 @@ bashcomp() {
fishcomp() {
pkgdesc="Fish shell completion for Docker"
depends=""
- install_if="$pkgname=$pkgver-r$pkgrel fish"
+ install_if="$pkgname=$pkgver-r$pkgrel fish<3" # fish above version 3 has docker completion
install -Dm644 "$_cli_builddir"/contrib/completion/fish/$pkgname.fish \
"$subpkgdir"/usr/share/fish/completions/$pkgname.fish