aboutsummaryrefslogtreecommitdiffstats
path: root/community/docker
diff options
context:
space:
mode:
authorJake Buchholz <tomalok@gmail.com>2019-07-22 20:46:57 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-07-22 20:08:42 -0300
commit0eda0ef48ed308cf452fbdb3ce573054ab56dd1a (patch)
treeadda2c559aea1d383b71ab2c3185d69471574e61 /community/docker
parente358716ef458cd009c01cb991c03b3349c768838 (diff)
downloadaports-0eda0ef48ed308cf452fbdb3ce573054ab56dd1a.tar.bz2
aports-0eda0ef48ed308cf452fbdb3ce573054ab56dd1a.tar.xz
community/docker: update to 19.03.0
Next major release of docker! Release notes at https://github.com/docker/docker-ce/releases/tag/v19.03.0
Diffstat (limited to 'community/docker')
-rw-r--r--community/docker/APKBUILD14
-rw-r--r--community/docker/docker-openrc-busybox-ash.patch14
-rw-r--r--community/docker/docker-openrc-fixes.patch32
3 files changed, 18 insertions, 42 deletions
diff --git a/community/docker/APKBUILD b/community/docker/APKBUILD
index 80403cc741..63c7378e51 100644
--- a/community/docker/APKBUILD
+++ b/community/docker/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Jake Buchholz <tomalok@gmail.com>
# Maintainer: Jake Buchholz <tomalok@gmail.com>
pkgname=docker
-pkgver=18.09.8
-_gitcommit=0dd43dd87fd530113bf44c9bba9ad8b20ce4637f # https://github.com/docker/docker-ce/commits/v$pkgver
+pkgver=19.03.0
+_gitcommit=aeac9490dc54c1d48b3d7ae9a46f5a19b78dcd3a # https://github.com/docker/docker-ce/commits/v$pkgver
_ver=${pkgver/_/-}-ce
pkgrel=0
pkgdesc="Pack, ship and run any application as a lightweight container"
@@ -16,7 +16,7 @@ makedepends="go go-md2man btrfs-progs-dev bash linux-headers coreutils lvm2-dev
install="$pkgname.pre-install"
# from https://github.com/docker/docker-ce/blob/v$pkgver/components/engine/vendor.conf
-_libnetwork_ver=e7933d41e7b206756115aa9df5e0599fc5169742
+_libnetwork_ver=fc5a7d91d54cc98f64fc28f9e288b46a0bee756c
_cobra_ver="0.0.3"
# secfixes:
@@ -212,8 +212,8 @@ cli_vim() {
done
}
-sha512sums="34cf91da732ebbde88f0c8cd39664130e6bd344b18d4643715a00e1c4062d0838a37650a8ee68fb371abd8f01910c7bdce1237af74a49cd63b5ed5382eaf00ed docker-18.09.8.tar.gz
-0a833510df0029999bfc05c23445a58a8b2ff165c0fb2fd5c411498d1e89b5b1990d2778b32346dd2b6d61c166ff707c6277a5d1937db6345c77d3825eb59875 libnetwork-e7933d41e7b206756115aa9df5e0599fc5169742.tar.gz
+sha512sums="ae843ef3d634b5e8e9e3e03890269aaa4edd01d9d2f5a8a6343c8c224a79f5df7c47aad6c59ea45b6aaac6aa0b0348d9ac54b76f037be742c0b4ed9dd160010b docker-19.03.0.tar.gz
+dea31fd82ab2d445fbd39fe15550a91f7e489a06f6dedd32ea1925f7e9a7971952d26b874f9687249609a0d204ea35da357e0a957b819df2026a0cf8109cb354 libnetwork-fc5a7d91d54cc98f64fc28f9e288b46a0bee756c.tar.gz
c38db9432a168f913b41a1e1b11d84bedfade82ff70791be9d343a6cc86b8a05b18bae344d67ebd8bae4c98662db7ac664a9dc86fa9b9ad4aa5c96cbf0178efb cobra-0.0.3.tar.gz
-33155a79799cc6c0520a030e1a9bdba60441776d612e5e255574b23bbce1c7a8e5d868284b05a8a92704be6bbb7db905388564e867986a705acbe4884ac58584 docker-openrc-fixes.patch
-9b24dc0c50904c3d12bb04c1a7df169651043ddbc258018647010a5aa01d8a19ad54d10ca79dce6d6283c81f4fa0cc8de417f6180dd824c5a588b22b23546cb5 docker-openrc-busybox-ash.patch"
+d796e6dcab6443a84064f3439dde46bc7e1989e1b52910b3e80a0af0ae1ddd288f0306a24c8d31032e24f5fd4218d2f25614752021355441f118ba2b524cfbd1 docker-openrc-fixes.patch
+fe79b65da989af9f579edf94763883793d479855b915a8ff217f75af3c3671f9d3e4beec63c4346df67dbfa6e38d4f9a1187efd5f1b7fca895700852dcffd871 docker-openrc-busybox-ash.patch"
diff --git a/community/docker/docker-openrc-busybox-ash.patch b/community/docker/docker-openrc-busybox-ash.patch
index 57ff7ed921..1f2b2de3d1 100644
--- a/community/docker/docker-openrc-busybox-ash.patch
+++ b/community/docker/docker-openrc-busybox-ash.patch
@@ -1,11 +1,11 @@
--- a/contrib/init/openrc/docker.initd
+++ b/contrib/init/openrc/docker.initd
-@@ -16,7 +16,7 @@
+@@ -13,7 +13,7 @@
- # Having non-zero limits causes performance problems due to accounting overhead
- # in the kernel. We recommend using cgroups to do container-local accounting.
-- ulimit -u unlimited
-+ ulimit -p unlimited
+ extra_started_commands="reload"
+
+-rc_ulimit="${DOCKER_ULIMIT:--c unlimited -n 1048576 -u unlimited}"
++rc_ulimit="${DOCKER_ULIMIT:--c unlimited -n 1048576 -p unlimited}"
+
+ retry="${DOCKER_RETRY:-TERM/60/KILL/10}"
- return 0
- }
diff --git a/community/docker/docker-openrc-fixes.patch b/community/docker/docker-openrc-fixes.patch
index 49a59cb98e..5ac8405238 100644
--- a/community/docker/docker-openrc-fixes.patch
+++ b/community/docker/docker-openrc-fixes.patch
@@ -1,37 +1,13 @@
-diff --git a/contrib/init/openrc/docker.confd b/contrib/init/openrc/docker.confd
-index 2444031..b5f431c 100644
---- a/contrib/init/openrc/docker.confd
-+++ b/contrib/init/openrc/docker.confd
-@@ -11,3 +11,6 @@
-
- # any other random options you want to pass to docker
- DOCKER_OPTS=""
-+
-+# disable grsecurity features
-+#disable_grsec="chroot_deny_chmod chroot_deny_mknod"
-diff --git a/contrib/init/openrc/docker.initd b/contrib/init/openrc/docker.initd
-index f2e1536..20de85b 100644
--- a/contrib/init/openrc/docker.initd
+++ b/contrib/init/openrc/docker.initd
-@@ -9,9 +9,21 @@
- start_stop_daemon_args="--background \
- --stderr \"${DOCKER_LOGFILE}\" --stdout \"${DOCKER_LOGFILE}\""
+@@ -17,6 +17,10 @@
+
+ retry="${DOCKER_RETRY:-TERM/60/KILL/10}"
-+grsecdir=/proc/sys/kernel/grsecurity
-+
+depend() {
+ need sysfs cgroups
+}
+
start_pre() {
checkpath -f -m 0644 -o root:docker "$DOCKER_LOGFILE"
-
-+ for i in $disable_grsec; do
-+ if [ -e "$grsecdir/$i" ]; then
-+ einfo " Disabling $i"
-+ echo 0 > "$grsecdir/$i"
-+ fi
-+ done
- ulimit -n 1048576
-
- # Having non-zero limits causes performance problems due to accounting overhead
+ }