aboutsummaryrefslogtreecommitdiffstats
path: root/community/dolphin
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-09-19 02:44:27 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-09-18 23:59:40 -0300
commit579faa0640483a135c6578b00c7eedb7e163056a (patch)
tree2c50972e7d04564219b7b6fd59b29a7c69569b37 /community/dolphin
parent40c1c4fecfee438a92109423634810e089bad6bd (diff)
downloadaports-579faa0640483a135c6578b00c7eedb7e163056a.tar.bz2
aports-579faa0640483a135c6578b00c7eedb7e163056a.tar.xz
community/dolphin: move from testing
Diffstat (limited to 'community/dolphin')
-rw-r--r--community/dolphin/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/dolphin/APKBUILD b/community/dolphin/APKBUILD
new file mode 100644
index 0000000000..ca5be912a3
--- /dev/null
+++ b/community/dolphin/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=dolphin
+pkgver=19.08.1
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/system/dolphin"
+pkgdesc="KDE File Manager"
+license="GPL-2.0-only"
+depends_dev="qt5-qtbase-dev kdoctools-dev kinit-dev kcmutils-dev knewstuff-dev
+ kcoreaddons-dev ki18n-dev kdbusaddons-dev kbookmarks-dev kconfig-dev
+ kio-dev kparts-dev solid-dev kiconthemes-dev kcompletion-dev
+ ktextwidgets-dev knotifications-dev kcrash-dev kwindowsystem-dev
+ phonon-dev baloo-dev baloo-widgets-dev kfilemetadata-dev kactivities-dev"
+makedepends="$depends_dev extra-cmake-modules ruby-test-unit"
+checkdepends="xvfb-run"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ # kfileitemmodeltest and placesitemmodeltest are broken
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(kfileitemmodel|placesitemmodel)test"
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="bcac00cdec1de2aab8b33f57f990c3b5c74f98d499c70adbc1a7f9b9528642221071c45716ea29f65c28733e2a282dd824e1dd4f2c305a4d2206345010aa5c87 dolphin-19.08.1.tar.xz"