aboutsummaryrefslogtreecommitdiffstats
path: root/community/domoticz
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-07 06:42:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-07 06:42:42 +0000
commit35cf08f099a0bd06d84f0167cee3f9bc150f3402 (patch)
treeff94413ac03aae9e5d7cd0516968c11f812c3c90 /community/domoticz
parent036fe643a4bc20304a819438e62594a30fbbf4cd (diff)
downloadaports-35cf08f099a0bd06d84f0167cee3f9bc150f3402.tar.bz2
aports-35cf08f099a0bd06d84f0167cee3f9bc150f3402.tar.xz
community/domoticz: fix boost patch
Diffstat (limited to 'community/domoticz')
-rw-r--r--community/domoticz/APKBUILD2
-rw-r--r--community/domoticz/boost-1.66.patch17
2 files changed, 3 insertions, 16 deletions
diff --git a/community/domoticz/APKBUILD b/community/domoticz/APKBUILD
index a27f3839e9..7b40e6288b 100644
--- a/community/domoticz/APKBUILD
+++ b/community/domoticz/APKBUILD
@@ -63,6 +63,6 @@ package() {
}
sha512sums="6c4e30b28fa4a5969ddf8a2c275e390394087b036af795921b114c7a734e966b546b33dd353b9aeefce39b30ce502067aadc8616c0fb25b3d97d58aa31922786 domoticz-3.8153.tar.gz
-e839452336c00557e56f999b878e9ff8d32b063241eb45803c0485046691b49371aee41436ccd729c67b3f82166897a248f4493740329984e20b71a245568f16 boost-1.66.patch
+42f89bf2311f20ce6fc4e1d24d6f7443f1572936aa813e364319a1d8eccf539f6ade593cbb00aceb98d24350cefd127b06e3c1c78083edec3c3e108e4aca7a02 boost-1.66.patch
724440da335f1e22c8dc181df62dac9ad2bcca98b39bff059de4be5901a93a0a8cb6864d92262092041d796ee7d3933f62cf337316d35a800bbb44f84a1709e0 domoticz.confd
3ddbd3848cce2247a52e4673307a078717d75cb3fea2937d9f2442d94dccd0efc63120f1b0324c7091ae158cd0ec4fd36334af43bb887d45ff4a93e6a96e9bd2 domoticz.initd"
diff --git a/community/domoticz/boost-1.66.patch b/community/domoticz/boost-1.66.patch
index 766ff02009..31993c0c74 100644
--- a/community/domoticz/boost-1.66.patch
+++ b/community/domoticz/boost-1.66.patch
@@ -9,27 +9,14 @@ Subject: [PATCH] Make compatible with boost 1.66
webserver/server.cpp | 4 ++--
3 files changed, 4 insertions(+), 4 deletions(-)
-diff --git a/msbuild/domoticz.vcxproj b/msbuild/domoticz.vcxproj
-index 5c526ed72..cee958414 100755
---- a/msbuild/domoticz.vcxproj
-+++ b/msbuild/domoticz.vcxproj
-@@ -58,7 +58,7 @@
- <PrecompiledHeader>Use</PrecompiledHeader>
- <WarningLevel>Level3</WarningLevel>
- <Optimization>Disabled</Optimization>
-- <PreprocessorDefinitions>WIN32;ENABLE_PYTHON;_DEBUG;PTW32_STATIC_LIB;WITH_OPENZWAVE;OPENZWAVE_USEDLL;WWW_ENABLE_SSL;_CONSOLE;%(PreprocessorDefinitions)</PreprocessorDefinitions>
-+ <PreprocessorDefinitions>WIN32;ENABLE_PYTHON;_DEBUG;PTW32_STATIC_LIB;WITH_OPENZWAVE;OPENZWAVE_USEDLL;WWW_ENABLE_SSL;_CONSOLE;BOOST_CONFIG_SUPPRESS_OUTDATED_MESSAGE;%(PreprocessorDefinitions)</PreprocessorDefinitions>
- <AdditionalIncludeDirectories>./Windows Libraries/Boost;./libusb;../MQTT;..\hardware\openzwave;./Windows Libraries/openssl;./Windows Libraries/Curl;./Windows Libraries/pthread;../hardware/plugins/Include;../tinyxpath;%(AdditionalIncludeDirectories)</AdditionalIncludeDirectories>
- <RuntimeLibrary>MultiThreadedDebugDLL</RuntimeLibrary>
- <EnablePREfast>false</EnablePREfast>
diff --git a/webserver/proxyclient.cpp b/webserver/proxyclient.cpp
index 6bd6b8771..86baef222 100644
--- a/webserver/proxyclient.cpp
+++ b/webserver/proxyclient.cpp
-@@ -771,7 +771,7 @@ namespace http {
+@@ -639,7 +639,7 @@
+ void CProxyManager::StartThread()
{
try {
- //boost::asio::ssl::context ctx(io_service, boost::asio::ssl::context::tlsv12_client);
- boost::asio::ssl::context ctx(io_service, boost::asio::ssl::context::sslv23);
+ boost::asio::ssl::context ctx(boost::asio::ssl::context::sslv23);
ctx.set_verify_mode(boost::asio::ssl::verify_none);