aboutsummaryrefslogtreecommitdiffstats
path: root/community/dub
diff options
context:
space:
mode:
authorGeod24 <pro.mathias.lang@gmail.com>2020-01-22 04:11:46 +0900
committerLeo <thinkabit.ukim@gmail.com>2020-01-22 04:15:42 +0100
commit48b48f1a0654e1dacb2cee418ddc1f455f51b371 (patch)
treed4cefee62239ee4bd8b900036166fdfa39d26813 /community/dub
parent95128bce202d85fc44acc248edf44346ea95bd07 (diff)
downloadaports-48b48f1a0654e1dacb2cee418ddc1f455f51b371.tar.bz2
aports-48b48f1a0654e1dacb2cee418ddc1f455f51b371.tar.xz
community/dub: move from testing
Diffstat (limited to 'community/dub')
-rw-r--r--community/dub/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/community/dub/APKBUILD b/community/dub/APKBUILD
new file mode 100644
index 0000000000..7d4362a559
--- /dev/null
+++ b/community/dub/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Mathias LANG <pro.mathias.lang@gmail.com>
+# Maintainer: Mathias LANG <pro.mathias.lang@gmail.com>
+pkgname=dub
+pkgver=1.19.0
+pkgrel=0
+pkgdesc="Package and build management system for D"
+url="http://code.dlang.org/"
+arch="all !ppc64le" # GDC does not support PPC64le
+license="MIT"
+depends="libcurl"
+makedepends="gcc-gdc gdmd bash curl-dev"
+source="$pkgname-$pkgver.zip::https://github.com/dlang/dub/archive/v$pkgver.zip"
+
+build() {
+ DC=gdmd GITVER="v$pkgver" ./build.sh
+}
+
+check() {
+ bin/dub test
+}
+
+package() {
+ install -s -D "$builddir/bin/dub" "$pkgdir/usr/bin/dub"
+}
+
+sha512sums="8cdeb1b2d07a003c02e47f43f56362aeac257110cc4a477f5fe2e83ff0b979f5e1b3aa553d75d97b16c22230ff823ac3cf9dec40c2c24211cac969bfe7deb522 dub-1.19.0.zip"