aboutsummaryrefslogtreecommitdiffstats
path: root/community/duo_unix
diff options
context:
space:
mode:
authorKris Reese <kris.reese@wwt.com>2019-01-30 20:58:28 -0600
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-14 16:32:53 +0000
commit8d366956d5d73aea2638b8bec72b0f2ad9c4b7c7 (patch)
tree56d2989f0e893b36f86d7eedb62f45b922d4a0b4 /community/duo_unix
parent1bbe8536b70daa63cfafc812af8279c2402cf8ff (diff)
downloadaports-8d366956d5d73aea2638b8bec72b0f2ad9c4b7c7.tar.bz2
aports-8d366956d5d73aea2638b8bec72b0f2ad9c4b7c7.tar.xz
community/duo_unix: improve aport
https://duo.com/docs/duounix Duo two-factor authentication for Unix systems with Pluggable Authentication Modules (PAM)
Diffstat (limited to 'community/duo_unix')
-rw-r--r--community/duo_unix/APKBUILD36
1 files changed, 12 insertions, 24 deletions
diff --git a/community/duo_unix/APKBUILD b/community/duo_unix/APKBUILD
index b7919afe66..8024b48984 100644
--- a/community/duo_unix/APKBUILD
+++ b/community/duo_unix/APKBUILD
@@ -1,39 +1,27 @@
# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Contributor: Kris Reese <ktreese@gmail.com>
# Maintainer: Paul Morgan <jumanjiman@gmail.com>
pkgname=duo_unix
pkgver=1.11.0
pkgrel=1
-pkgdesc="duosecurity.com two-factor authentication"
-url="https://duo.com/support/documentation/duounix"
+pkgdesc="Duo two-factor authentication for Unix systems with Pluggable Authentication Modules (PAM)"
+url="https://duo.com/docs/duounix"
arch="all"
-license="GPL-2.0-only"
-depends=""
-depends_dev="openssl-dev zlib-dev"
-makedepends="$depends_dev automake autoconf libtool"
-options="suid"
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/duosecurity/duo_unix/archive/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgname-$pkgver
+license="GPL-2.0"
+depends="openssh openssh-server-pam"
+makedepends="openssl-dev linux-pam-dev libtool"
+subpackages="$pkgname-doc"
+source="https://dl.duosecurity.com/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+options="suid !check" #make check fails with error: redefinition of 'fopen'
-prepare() {
- default_prepare
- ./bootstrap
-}
build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc/duo \
- --mandir=/usr/share/man \
- --localstatedir=/var
+ ./configure --with-pam --prefix=/usr
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="9a58de49208511a12942575959d0c3a438a216f25b478035cbf2bbd04d2c644ed45f32d77ef947d8b181e7005fd5954990aab3c9d9301fa3f790918faad43e6a duo_unix-1.11.0.tar.gz"
+sha512sums="d871173f9e121f1d42e4161b1b2c44bbee001e390c6d45a44f68e74b4bf5b8562ac5cef8f8910d9148001955f8a20380331bf2d6f0e77d9af20d739fc0118678 duo_unix-1.11.1.tar.gz"