aboutsummaryrefslogtreecommitdiffstats
path: root/community/dynamips/APKBUILD
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2018-12-03 10:26:31 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-17 09:00:30 +0000
commit20b06b3a5a196d248d8b0e66fc1beb3925667c72 (patch)
tree75004c7d93f8829f7a2c953081d83b7b35b4a2ca /community/dynamips/APKBUILD
parent8b256dcd696715633a9f885f8e8e8de0017d8f9a (diff)
downloadaports-20b06b3a5a196d248d8b0e66fc1beb3925667c72.tar.bz2
aports-20b06b3a5a196d248d8b0e66fc1beb3925667c72.tar.xz
community/dynamips: fix byte order detection
Use the generic gcc/clang/suncc __BYTE_ORDER__ macro to detect platform byte order instead of hard-coded architecture detection which is wrong for ppc64le (always assumes POWER is big-endian) and lacks any knowledge of mips*. This change covers s390x too so remove s390x-support.patch.
Diffstat (limited to 'community/dynamips/APKBUILD')
-rw-r--r--community/dynamips/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/dynamips/APKBUILD b/community/dynamips/APKBUILD
index 5c8f62bef4..0013d974eb 100644
--- a/community/dynamips/APKBUILD
+++ b/community/dynamips/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=dynamips
pkgver=0.2.18
-pkgrel=0
+pkgrel=1
pkgdesc="Cisco router emulator"
url="https://github.com/GNS3/dynamips"
arch="all"
@@ -10,7 +10,7 @@ license="GPL-2.0"
makedepends="cmake libpcap-dev libelf-dev linux-headers paxmark libnsl-dev"
subpackages="$pkgname-doc"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/GNS3/${pkgname}/archive/v${pkgver}.tar.gz
- s390x-support.patch"
+ detect-byte-order.patch"
builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -36,4 +36,4 @@ package() {
}
sha512sums="d66e32d72ecc9ebff5232377ac9aa5b966ceb08884cc7f8dc4a8cf3f56305e7cefd677624ba66278f6603a3b275c384bd0ff3905932461b1f8056106cd272a4c dynamips-0.2.18.tar.gz
-151f9c7d53c0edd9d300b3e84ce50d500018a533d6d131609ac0c25244db640d65d2322104c126e7c0e311cc0b197c07976f21fa28909a92d48cf31b6208431b s390x-support.patch"
+d3beb4ddda4ca571a36f2333609db48126c0f6629adf39a985cedb1741356f415f33c82c56b69802955869c6741655476253c4ea4e8ef1461411cc52e411e429 detect-byte-order.patch"