aboutsummaryrefslogtreecommitdiffstats
path: root/community/easypki
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-04-10 19:23:32 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-04-10 19:23:37 +0000
commit001f3f7dc635c4c0dd6fee7f29e57c9c77af4d55 (patch)
tree9e54510e6199446083531d906606bcbc55664a99 /community/easypki
parentab1dfb44802d28509987f1bf15badb1817be89d5 (diff)
downloadaports-001f3f7dc635c4c0dd6fee7f29e57c9c77af4d55.tar.bz2
aports-001f3f7dc635c4c0dd6fee7f29e57c9c77af4d55.tar.xz
community/easypki: move glide to prepare
Diffstat (limited to 'community/easypki')
-rw-r--r--community/easypki/APKBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/community/easypki/APKBUILD b/community/easypki/APKBUILD
index fa0f815dfb..22ce5b901a 100644
--- a/community/easypki/APKBUILD
+++ b/community/easypki/APKBUILD
@@ -18,11 +18,17 @@ source="easypki-$pkgver.tar.gz::https://github.com/google/easypki/archive/v$pkgv
"
builddir="$srcdir/easypki-$pkgver"
+prepare() {
+ export GOPATH="$startdir"
+ cd "$builddir"
+ cp "$srcdir"/glide.yaml "$srcdir"/glide.lock .
+ glide install --skip-test
+ default_prepare
+}
+
build() {
- export GOPATH="$startdir"
- cd "$builddir"
- cp "$srcdir"/glide.yaml "$srcdir"/glide.lock .
- glide install --skip-test
+ export GOPATH="$startdir"
+ cd "$builddir"
go build -v -ldflags "-s -w" \
-o "$builddir"/easypki ./cmd/easypki
}
@@ -37,14 +43,14 @@ check() {
}
glide_init() {
- abuild clean deps unpack prepare
- cd "$builddir"
- export GOPATH="$startdir"
- rm -f glide.yaml glide.lock
- glide init --non-interactive
- glide update
- cp glide.yaml glide.lock "$startdir"
- cd "$startdir" && abuild checksum clean
+ abuild clean deps unpack prepare
+ cd "$builddir"
+ export GOPATH="$startdir"
+ rm -f glide.yaml glide.lock
+ glide init --non-interactive
+ glide update
+ cp glide.yaml glide.lock "$startdir"
+ cd "$startdir" && abuild checksum clean
}