aboutsummaryrefslogtreecommitdiffstats
path: root/community/ecryptfs-utils
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-01-31 11:26:12 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-01-31 11:26:12 +0200
commitcf0a5d75f1fd50eb08833397df5bb889938faa9f (patch)
tree27d63edb87a3d2b2dbfedae161f43e7c04ee7954 /community/ecryptfs-utils
parentad3f68e3e5e9153aed56f3e551600ab5ceee6dd8 (diff)
downloadaports-cf0a5d75f1fd50eb08833397df5bb889938faa9f.tar.bz2
aports-cf0a5d75f1fd50eb08833397df5bb889938faa9f.tar.xz
community/ecryptfs-utils: moved from testing
Diffstat (limited to 'community/ecryptfs-utils')
-rw-r--r--community/ecryptfs-utils/APKBUILD57
-rw-r--r--community/ecryptfs-utils/fix-build.patch11
-rw-r--r--community/ecryptfs-utils/fix-stdout-flush.patch30
3 files changed, 98 insertions, 0 deletions
diff --git a/community/ecryptfs-utils/APKBUILD b/community/ecryptfs-utils/APKBUILD
new file mode 100644
index 0000000000..68d1c39ed5
--- /dev/null
+++ b/community/ecryptfs-utils/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: k0r10n <k0r10n.dev@gmail.com>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=ecryptfs-utils
+pkgver=111
+pkgrel=2
+pkgdesc="Enterprise-class stacked cryptographic filesystem for Linux"
+url="https://launchpad.net/ecryptfs"
+arch="all"
+license="GPL"
+depends="cryptsetup rsync"
+depends_dev="keyutils-dev linux-pam-dev nss-dev linux-headers"
+makedepends="$depends_dev swig intltool gettext python2-dev perl-dev"
+install=""
+options="suid"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py-ecryptfs-utils:py"
+source="http://launchpad.net/ecryptfs/trunk/${pkgver}/+download/${pkgname}_${pkgver}.orig.tar.gz
+ fix-build.patch
+ fix-stdout-flush.patch
+ "
+
+builddir="$srcdir"/${pkgname}-${pkgver}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ chmod +s "$pkgdir"/sbin/mount.ecryptfs_private || return 1
+}
+
+py() {
+ pkgdesc="python bindings for $pkgname"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/py* "$subpkgdir"/usr/lib/
+}
+
+md5sums="83513228984f671930752c3518cac6fd ecryptfs-utils_111.orig.tar.gz
+d42bb467a5912df0d2e83e9fdd2553dd fix-build.patch
+12c5334bb856151cdbd70d174ce88c01 fix-stdout-flush.patch"
+sha256sums="112cb3e37e81a1ecd8e39516725dec0ce55c5f3df6284e0f4cc0f118750a987f ecryptfs-utils_111.orig.tar.gz
+7f1038542a3aaba0cf5dd898f2e6e2ffbb9792fecff1a4eb532bb8bc39907fb9 fix-build.patch
+fe38e0813485fdc09832fe81538089f772372bc830a3d8140d9b3f8ed99670d2 fix-stdout-flush.patch"
+sha512sums="d8643f3a1f9981fecc6a08b4aa0adb6272e7340db794f6e7507cba7b712247c6beb239f27875eab6e38a69b45bc2476e6bf6b4485eb82d58f65cc469f8613c18 ecryptfs-utils_111.orig.tar.gz
+09ff196e6d3ef54ef57e22e78a4af748c2989928a5c8bc3ece1f8c21c5f301b7e56142c5098111ac853ac88c1b2ee2d0b5c606a210fb53cdf0fde534aa0af92f fix-build.patch
+c9eb924890a8fa3ffe8b8344a493419cf93336743b1a3a8dba984f62f8eb7a43ed6b6dbbbb7efe9e7fc84b60e71d7100f042a72c407fc9e8c4fcbeeb73d848a3 fix-stdout-flush.patch"
diff --git a/community/ecryptfs-utils/fix-build.patch b/community/ecryptfs-utils/fix-build.patch
new file mode 100644
index 0000000000..6758fdb5b5
--- /dev/null
+++ b/community/ecryptfs-utils/fix-build.patch
@@ -0,0 +1,11 @@
+--- ecryptfs-utils-111.orig/src/utils/mount.ecryptfs_private.c 2016-01-22 18:04:52.000000000 +0200
++++ ecryptfs-utils-111/src/utils/mount.ecryptfs_private.c 2017-01-20 08:39:31.877975729 +0200
+@@ -235,7 +235,7 @@
+ * deceive other programs with a crafted /proc/self/*. See
+ * https://launchpad.net/bugs/1530566 for more details.
+ */
+- __SWORD_TYPE f_type_whitelist[] = {
++ static const uint32_t f_type_whitelist[] = {
+ 0x61756673 /* AUFS_SUPER_MAGIC */,
+ 0x9123683E /* BTRFS_SUPER_MAGIC */,
+ 0x00C36400 /* CEPH_SUPER_MAGIC */,
diff --git a/community/ecryptfs-utils/fix-stdout-flush.patch b/community/ecryptfs-utils/fix-stdout-flush.patch
new file mode 100644
index 0000000000..7f097be242
--- /dev/null
+++ b/community/ecryptfs-utils/fix-stdout-flush.patch
@@ -0,0 +1,30 @@
+diff -ru ecryptfs-utils-111.orig/src/libecryptfs/key_management.c ecryptfs-utils-111/src/libecryptfs/key_management.c
+--- ecryptfs-utils-111.orig/src/libecryptfs/key_management.c 2015-12-21 22:38:59.000000000 +0200
++++ ecryptfs-utils-111/src/libecryptfs/key_management.c 2017-01-31 11:11:55.190995428 +0200
+@@ -1245,6 +1245,7 @@
+ if (prompt != NULL) {
+ printf("%s: ", prompt);
+ }
++ fflush(stdout);
+ ecryptfs_disable_echo(&current_settings);
+ if (fgets(passphrase,
+ ECRYPTFS_MAX_PASSWORD_LENGTH+2, stdin) == NULL) {
+diff -ru ecryptfs-utils-111.orig/src/utils/io.c ecryptfs-utils-111/src/utils/io.c
+--- ecryptfs-utils-111.orig/src/utils/io.c 2015-12-21 22:38:59.000000000 +0200
++++ ecryptfs-utils-111/src/utils/io.c 2017-01-31 11:11:34.127379788 +0200
+@@ -70,6 +70,7 @@
+ int c;
+
+ printf("%s: ", prompt);
++ fflush(stdout);
+ temp = malloc(length);
+ if (!temp) {
+ rc = -ENOMEM;
+@@ -122,6 +123,7 @@
+ int rc = 0;
+ int c;
+
++ fflush(stdout);
+ if (echo == ECRYPTFS_ECHO_OFF) {
+ rc = disable_echo(&saved_settings);
+ if (rc)