aboutsummaryrefslogtreecommitdiffstats
path: root/community/edk2
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-10-15 17:47:02 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-10-15 17:47:18 +0000
commitefaa69489b5eb0a1778a9ee8f03080fd24c8b240 (patch)
treee8d180b8c390192f61cef15111b9bbf610d430dc /community/edk2
parentab7bdc48174243acc167e9513f53c7de6f58c2e8 (diff)
downloadaports-efaa69489b5eb0a1778a9ee8f03080fd24c8b240.tar.bz2
aports-efaa69489b5eb0a1778a9ee8f03080fd24c8b240.tar.xz
community/edk2: fix build on aarch64
Diffstat (limited to 'community/edk2')
-rw-r--r--community/edk2/APKBUILD4
-rw-r--r--community/edk2/disable-werror.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/community/edk2/APKBUILD b/community/edk2/APKBUILD
index 8cb8520aba..c13a7ae785 100644
--- a/community/edk2/APKBUILD
+++ b/community/edk2/APKBUILD
@@ -18,6 +18,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/tianocore/$pkgname/archive/$
https://www.openssl.org/source/openssl-$_sslver.tar.gz
http://www.jhauser.us/arithmetic/SoftFloat-$_sfver.zip
build-hack.patch
+ disable-werror.patch
"
builddir="$srcdir/$pkgname-$_realver"
@@ -103,4 +104,5 @@ ovmf() {
sha512sums="439ed3d1ba0cfe7db4aa1a0b1298a4906e289bcb5600f9c248a3fcd9b9894b5591062c8f720ca432513a27e56ef0b858d15e33b38602258b09cecd5d2f9959a4 edk2-0.0.201908.tar.gz
b54025fbb4fe264466f3b0d762aad4be45bd23cd48bdb26d901d4c41a40bfd776177e02230995ab181a695435039dbad313f4b9a563239a70807a2e19ecf045d openssl-1.1.1b.tar.gz
3fedcd0060affb2d8fc7995894133cfed6a495c8717df0d30c89885223c38749f25743598383736036332dad6353c6a3f027f5a94a696660f7c4b607e33e534c SoftFloat-3e.zip
-a7d4ab2c82b62ba01c86e59f53bd3896d661c9bfbb9db9598734155b66d5fe03eca4a2a9993a14d3bf555992c6d01ba5d7a15868ff9ec6ed98b8a9b3895bb7df build-hack.patch"
+a7d4ab2c82b62ba01c86e59f53bd3896d661c9bfbb9db9598734155b66d5fe03eca4a2a9993a14d3bf555992c6d01ba5d7a15868ff9ec6ed98b8a9b3895bb7df build-hack.patch
+a7c566f2347ee08ee062be45c340f38dc047c31b1541b8eca994692c8d04f48fea45830dce5933699e9bf9207deeaf22e09639c605a896171f01d9bcd68878ce disable-werror.patch"
diff --git a/community/edk2/disable-werror.patch b/community/edk2/disable-werror.patch
new file mode 100644
index 0000000000..73f19d4e5c
--- /dev/null
+++ b/community/edk2/disable-werror.patch
@@ -0,0 +1,11 @@
+--- ./BaseTools/Source/C/Makefiles/header.makefile.orig
++++ ./BaseTools/Source/C/Makefiles/header.makefile
+@@ -73,7 +73,7 @@
+ -Wno-deprecated-declarations -Wno-self-assign -Wno-unused-result -nostdlib -g
+ else
+ BUILD_CFLAGS = -MD -fshort-wchar -fno-strict-aliasing -fwrapv \
+--fno-delete-null-pointer-checks -Wall -Werror \
++-fno-delete-null-pointer-checks -Wall \
+ -Wno-deprecated-declarations -Wno-stringop-truncation -Wno-restrict \
+ -Wno-unused-result -nostdlib -g
+ endif