aboutsummaryrefslogtreecommitdiffstats
path: root/community/elasticsearch
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-09-14 09:11:34 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-09-14 09:29:43 +0000
commit0b61cee9c7228aa3c64e058e75f393bf01725e78 (patch)
tree4352196f44ee77640f40edc9da4c4dd1393c7b56 /community/elasticsearch
parent98710e72af05a1f9a2938693125507006bf7f019 (diff)
downloadaports-0b61cee9c7228aa3c64e058e75f393bf01725e78.tar.bz2
aports-0b61cee9c7228aa3c64e058e75f393bf01725e78.tar.xz
community/elasticsearch: forcibly relocate plugins directory
Diffstat (limited to 'community/elasticsearch')
-rw-r--r--community/elasticsearch/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/community/elasticsearch/APKBUILD b/community/elasticsearch/APKBUILD
index 4f269b4d7c..b0039855cf 100644
--- a/community/elasticsearch/APKBUILD
+++ b/community/elasticsearch/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=elasticsearch
pkgver=6.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="Open Source, Distributed, RESTful Search Engine"
url="https://www.elastic.co/products/elasticsearch"
arch="x86 x86_64 ppc64le"
@@ -89,6 +89,13 @@ package() {
install -m644 -D "$srcdir"/README.alpine \
"$docdir"
+
+ # Enforce plugins directory relocation
+ # Passing the "path.plugins" or "es.default.path.plugins" arguments
+ # at runtime does not seem to work in v6.4,
+ # it generates an exception if "$destdir"/plugins does not exist.
+ # The plugins directory will be shared among all ES instances.
+ ln -s /var/lib/elasticsearch/_default/plugins "$destdir"/plugins
}
_builtin_module() {