aboutsummaryrefslogtreecommitdiffstats
path: root/community/elasticsearch
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-09-13 08:01:58 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-09-13 12:08:39 +0000
commitc0a7b7fae67a3a1be82e7fd2544e6aba432e3ed4 (patch)
tree8ab4c78b574c389d9b4c87e90c7c46f563566717 /community/elasticsearch
parent20f73acc9e5a949ed1a364d2fd69786313d1456e (diff)
downloadaports-c0a7b7fae67a3a1be82e7fd2544e6aba432e3ed4.tar.bz2
aports-c0a7b7fae67a3a1be82e7fd2544e6aba432e3ed4.tar.xz
community/elasticsearch: upgrade to 6.4.0
- Fix install of subdirectories - Fix config file permissions - Make startup script compatible with busybox - Fix initd statup options for v6.4, adjust depends - Modernize APKBUILD
Diffstat (limited to 'community/elasticsearch')
-rw-r--r--community/elasticsearch/APKBUILD30
-rw-r--r--community/elasticsearch/elasticsearch.initd3
2 files changed, 19 insertions, 14 deletions
diff --git a/community/elasticsearch/APKBUILD b/community/elasticsearch/APKBUILD
index 7e5c8b7f48..fe9128b1ba 100644
--- a/community/elasticsearch/APKBUILD
+++ b/community/elasticsearch/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=elasticsearch
-pkgver=6.1.1
+pkgver=6.4.0
pkgrel=0
pkgdesc="Open Source, Distributed, RESTful Search Engine"
url="https://www.elastic.co/products/elasticsearch"
@@ -11,10 +11,14 @@ depends="java-jna-native>=4.1 openjdk8-jre bash"
makedepends=""
install="$pkgname.pre-install"
subpackages="$pkgname-doc"
+options="!check" # no test suite
+pkgusers="elastico"
+pkggroups="elastico"
source="https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd
README.alpine
+ busybox-mktemp.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -51,24 +55,23 @@ package() {
local heapsize="256m"
cd "$builddir"
-
install -dm755 "$destdir"/lib "$destdir"/modules "$destdir"/bin
- install -m644 -t "$destdir"/lib lib/* || return 1
+ cp -R lib/* "$destdir"/lib
install -dm755 "$docdir"
- install -dm755 "$confdir"
- install -m644 -t "$confdir" config/* || return 1
+ install -dm755 -o elastico -g elastico "$confdir"
+ install -m644 -t "$confdir" config/*
# remove windows files
find bin -type f -name *.bat -exec rm -f {} \;
find bin -type f -name *.exe -exec rm -f {} \;
# ES bin script parses the new jvm.options file
- install -m755 -t "$destdir"/bin bin/* || return 1
+ cp -R bin/* "$destdir"/bin
# ES does not run without a transport module
install -dm755 "$destdir/modules/$default_module"
- install -m644 -t "$destdir/modules/$default_module" modules/"$default_module"/* || return 1
+ install -m644 -t "$destdir/modules/$default_module" modules/"$default_module"/*
# reduce heap sizes
sed -i \
@@ -77,13 +80,13 @@ package() {
$confdir/jvm.options
install -m755 -D "$srcdir"/$pkgname.initd \
- "$pkgdir"/etc/init.d/$pkgname || return 1
+ "$pkgdir"/etc/init.d/$pkgname
install -m644 -D "$srcdir"/$pkgname.confd \
- "$pkgdir"/etc/conf.d/$pkgname || return 1
+ "$pkgdir"/etc/conf.d/$pkgname
install -m644 -D "$srcdir"/README.alpine \
- "$docdir" || return 1
+ "$docdir"
}
_builtin_module() {
@@ -94,7 +97,8 @@ _builtin_module() {
install -m644 -t "$destdir" "$builddir"/modules/$name/*
}
-sha512sums="dcc23ef80ad2545490508d3e9db2fd0e6ae9a99cece0990f537c522265961dad234734548d1d86288af7f65a6ee681f5624d2c0e71df0e1dcc32fdb56dcefe92 elasticsearch-6.1.1.tar.gz
-dc916861497d4a589d6b3ab70d90ff9970e4d57003ed82d08c5f90dec337f995dcabf2556b7a27ade926e846ad435392f7845acfe9280dce17b4c172d85328ae elasticsearch.initd
+sha512sums="6f465378a51c487f1f6a84a0843ac1038db60170ee8a5d96874a759f6dbbf2de9f7bcbbf55616f49f28f1098c82f2e585c917267d02b8b1f43627a1984b3da66 elasticsearch-6.4.0.tar.gz
+3957f706d26426772904826a85d4cc96908342154a6089a941cd87230580ea6dccea60b1e84cd08754885d2771babe2026174455836fc993df40fe2892442469 elasticsearch.initd
2ab1baf1b5c8782f3f371ba221aadd3e841abc62175f0b1ddcfc68d711e2370465124e076f8cc2e549c25a1da9db8c90172b2f410bd6bbe4153f0e831620b6ba elasticsearch.confd
-6de81485cdc059afef58382862e4155482463fde0b604aaa8dbe904c778b841467c4a383a5e54acd09e3436f1fb7be9923e001fb77bd3d7894e113a5e0f4036b README.alpine"
+6de81485cdc059afef58382862e4155482463fde0b604aaa8dbe904c778b841467c4a383a5e54acd09e3436f1fb7be9923e001fb77bd3d7894e113a5e0f4036b README.alpine
+1f9d13bbc42c04c523ef4e9ce734f919ec3d79748d78f288ed3dd725cf7c74e83d66d8b48fbc782b27b1a760096a647cb33773578071710542b19fda18ea0b84 busybox-mktemp.patch"
diff --git a/community/elasticsearch/elasticsearch.initd b/community/elasticsearch/elasticsearch.initd
index 660c822437..ff40813ad1 100644
--- a/community/elasticsearch/elasticsearch.initd
+++ b/community/elasticsearch/elasticsearch.initd
@@ -22,7 +22,6 @@ name="Elasticsearch"
: ${create_logs_dir:="yes"}
elastic_opts="
- -Epath.conf=$conf_dir
-Epath.data=$default_data_dir
-Epath.logs=$default_logs_dir
$elastic_opts
@@ -40,6 +39,7 @@ java_opts="
# export ES_DIRECT_SIZE=
export ES_JAVA_OPTS="$java_opts"
export ES_JVM_OPTIONS="$conf_dir/jvm.options"
+export ES_PATH_CONF="$conf_dir"
nice="0"
pidfile="/run/$SVCNAME.sd.pid"
@@ -49,6 +49,7 @@ command_args="$elastic_opts 1>/dev/null 2>>$default_logs_dir/error.log"
depends() {
use net
+ after firewall
}
in_contr() {