aboutsummaryrefslogtreecommitdiffstats
path: root/community/elixir
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-10-15 01:29:01 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-10-20 22:17:09 +0200
commit165d9f90c3ee8b93e6dfcc58f9ac0e81581ebfb5 (patch)
tree67228c1f859777fb24467335113c9e7315cc0a62 /community/elixir
parentf83eb6cae73aacb21f7c5c2bed75d46db16eba42 (diff)
downloadaports-165d9f90c3ee8b93e6dfcc58f9ac0e81581ebfb5.tar.bz2
aports-165d9f90c3ee8b93e6dfcc58f9ac0e81581ebfb5.tar.xz
community/elixir: upgrade to 1.9.2
Diffstat (limited to 'community/elixir')
-rw-r--r--community/elixir/APKBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/community/elixir/APKBUILD b/community/elixir/APKBUILD
index 35fae74df8..e75793ee4e 100644
--- a/community/elixir/APKBUILD
+++ b/community/elixir/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Daniel Isaksen <d@duniel.no>
# Maintainer: Marlus Saraiva <marlus.saraiva@gmail.com>
pkgname=elixir
-pkgver=1.9.1
-pkgrel=1
+pkgver=1.9.2
+pkgrel=0
pkgdesc="Elixir is a dynamic, functional language designed for building scalable and maintainable applications"
-url="https://elixir-lang.org"
+url="https://elixir-lang.org/"
arch="noarch"
license="Apache-2.0"
depends="erlang erlang-inets erlang-ssl erlang-public-key erlang-asn1
@@ -13,25 +13,19 @@ depends="erlang erlang-inets erlang-ssl erlang-public-key erlang-asn1
makedepends="erlang-crypto erlang-syntax-tools erlang-parsetools erlang-eunit
erlang-tools"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/elixir-lang/elixir/archive/v$pkgver.tar.gz
- fix-release-pid-rpc-tests.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/elixir-lang/elixir/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$builddir"
- LANG="en_US.UTF-8" make -j1
+ LANG="en_US.UTF-8" make
}
check() {
- cd "$builddir"
-
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" PREFIX=/usr install
}
-sha512sums="4cfc672d3a2d02e044ffa305ae2986658a431a264b7e06b0fde1773d8d062bde27ea06f0d31433107ef8bfdf6e931c75c6a39de81bc54b275e06edbe0cc87bda elixir-1.9.1.tar.gz
-06f66a26c8a9d938f3231dc27dc4768a48e17eb633f6c7d9c62409b136bdd4e31789feb58c77c61a68ce5c940fd4282a8348e6fbcbad8d1d4a8f75b31a3e2fb0 fix-release-pid-rpc-tests.patch"
+sha512sums="7cd5844f525d0f810563b9bfb76d2814dba1623b0abc0b3befecdaae43557fee1b86e5f51359aa95353ffd732671d424e35b5054a13dea59ea03ac54fe85a498 elixir-1.9.2.tar.gz"