aboutsummaryrefslogtreecommitdiffstats
path: root/community/eom
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-05-14 15:09:49 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-09 15:18:36 +0000
commitbf7478bf9950d4b435ce7601cef4123bcdc2edbc (patch)
treeb9b449b5e91cd15d27bd7068ec40c183ee72faac /community/eom
parent6aca75b68078ec5970313477d341a5b6f3267075 (diff)
downloadaports-bf7478bf9950d4b435ce7601cef4123bcdc2edbc.tar.bz2
aports-bf7478bf9950d4b435ce7601cef4123bcdc2edbc.tar.xz
community/eom: modernize abuild
Diffstat (limited to 'community/eom')
-rw-r--r--community/eom/APKBUILD23
1 files changed, 6 insertions, 17 deletions
diff --git a/community/eom/APKBUILD b/community/eom/APKBUILD
index 28c554a7dd..58280c92bf 100644
--- a/community/eom/APKBUILD
+++ b/community/eom/APKBUILD
@@ -11,23 +11,12 @@ depends="mate-icon-theme libxml2-utils"
depends_dev=""
makedepends="$depends_dev glib-dev gtk+3.0-dev itstool mate-desktop-dev
libexif-dev lcms2-dev dconf-dev dbus-dev librsvg-dev libxslt-dev libpeas-dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,14 +24,14 @@ build() {
--with-gtk=2.0 \
--enable-introspection=no \
--disable-schemas-compile \
- --prefix=/usr || return 1
+ --prefix=/usr
- make || return 1
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="${pkgdir}" install || return 1
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
}
sha512sums="971ce70b0fbeb385c88f3701e52b09bcac5dd415cb103ef5b2bcd0e48ba2916e5c13316b55649a0904527025c960f3f2a78e011ec723815fa96edd5a2fb3da7f eom-1.18.1.tar.xz"