aboutsummaryrefslogtreecommitdiffstats
path: root/community/exo
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/exo
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/exo')
-rw-r--r--community/exo/APKBUILD43
-rw-r--r--community/exo/mailreader-claws-mail.patch10
2 files changed, 53 insertions, 0 deletions
diff --git a/community/exo/APKBUILD b/community/exo/APKBUILD
new file mode 100644
index 0000000000..8dc131e247
--- /dev/null
+++ b/community/exo/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=exo
+pkgver=0.11.5
+pkgrel=0
+pkgdesc="Extensions to Xfce by os-cillation"
+url="http://www.os-cillation.com/article.php?sid=40"
+arch="all"
+license="GPL-2.0 LGPL-2"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+depends="hicolor-icon-theme"
+makedepends="gtk+2.0-dev libxfce4util-dev libxfce4ui-dev perl perl-uri
+ libnotify-dev gtk-doc"
+install=
+source="http://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
+ mailreader-claws-mail.patch
+ "
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gtk-doc
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="c1aeb6dbdb60ab3c19797adcd3e832871960b8a91469d5f96f5fb23bc44794a9b0cf91c910b27f001196d75439baf23565b8860d0bad72799134b2018d3b8463 exo-0.11.5.tar.bz2
+957350c34b9209b89b051ccf9800f7d0e9ce580ad4161366bab0984d4d4d1f63d20bcb9fd5c22abffc0151c377a5bc7ad5c1b24b0183e997ebdd92ab61ee1c2b mailreader-claws-mail.patch"
diff --git a/community/exo/mailreader-claws-mail.patch b/community/exo/mailreader-claws-mail.patch
new file mode 100644
index 0000000000..eb4cf0ebd0
--- /dev/null
+++ b/community/exo/mailreader-claws-mail.patch
@@ -0,0 +1,10 @@
+--- ./exo-helper/helpers/helpers.rc.orig
++++ ./exo-helper/helpers/helpers.rc
+@@ -5,6 +5,6 @@
+ #
+
+ WebBrowser=firefox
+-MailReader=thunderbird
++MailReader=claws-mail
+ TerminalEmulator=xfce4-terminal
+ FileManager=Thunar