aboutsummaryrefslogtreecommitdiffstats
path: root/community/extra-cmake-modules
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-10-17 17:41:19 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-20 19:49:47 +0000
commit93fe6d1ba0e49a7acb827bc7159bf5709d11e0cf (patch)
tree487f61c11887ad4788225ccf1d026ed6c121e6c9 /community/extra-cmake-modules
parent2aefaab831e76099e103a2a1702652f3a6c61f62 (diff)
downloadaports-93fe6d1ba0e49a7acb827bc7159bf5709d11e0cf.tar.bz2
aports-93fe6d1ba0e49a7acb827bc7159bf5709d11e0cf.tar.xz
community/kde-frameworks: fix linting errors
Closes !517
Diffstat (limited to 'community/extra-cmake-modules')
-rw-r--r--community/extra-cmake-modules/APKBUILD12
-rw-r--r--community/extra-cmake-modules/disable-KDEFetchTranslations.patch13
2 files changed, 6 insertions, 19 deletions
diff --git a/community/extra-cmake-modules/APKBUILD b/community/extra-cmake-modules/APKBUILD
index 751f61cea3..059df6a1ba 100644
--- a/community/extra-cmake-modules/APKBUILD
+++ b/community/extra-cmake-modules/APKBUILD
@@ -15,13 +15,13 @@ subpackages="$pkgname-doc"
source="http://download.kde.org/stable/frameworks/${pkgver%.*}/extra-cmake-modules-$pkgver.tar.xz"
prepare() {
- default_prepare
-
- mkdir "$builddir"/build
+ default_prepare
+
+ mkdir "$builddir"/build
}
build() {
- cd "$builddir"/build
+ cd "$builddir"/build
cmake "$builddir" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_TESTING=ON \
@@ -30,13 +30,13 @@ build() {
}
check() {
- cd "$builddir"/build
+ cd "$builddir"/build
# Broken tests
CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "(KDEFetchTranslations|KDEInstallDirsTest.relative_or_absolute_usr|KDEInstallDirsTest.relative_or_absolute_qt)"
}
package() {
- cd "$builddir"/build
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install/fast
}
diff --git a/community/extra-cmake-modules/disable-KDEFetchTranslations.patch b/community/extra-cmake-modules/disable-KDEFetchTranslations.patch
deleted file mode 100644
index ab2c11b598..0000000000
--- a/community/extra-cmake-modules/disable-KDEFetchTranslations.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
-index 9df03eb..040e184 100644
---- a/tests/CMakeLists.txt
-+++ b/tests/CMakeLists.txt
-@@ -111,7 +111,6 @@ endif()
-
- add_test_macro(ExecuteCoreModules dummy)
- add_test_macro(ExecuteKDEModules dummy)
--add_test_macro(KDEFetchTranslations dummy)
-
- add_test_macro(KDEInstallDirsTest.relative_or_absolute dummy)
- add_test_variant(KDEInstallDirsTest.vars_in_sync_no_args
-