aboutsummaryrefslogtreecommitdiffstats
path: root/community/faenza-icon-theme
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-10 11:01:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-10 11:01:01 +0000
commit4e6848e00f109290b87d213aee9e5584cca12876 (patch)
treeb694cec9ef3e78adcfc72ea6e5f458580354b728 /community/faenza-icon-theme
parent8703a3663e3fe64729764971ec24527ea6247bf9 (diff)
downloadaports-4e6848e00f109290b87d213aee9e5584cca12876.tar.bz2
aports-4e6848e00f109290b87d213aee9e5584cca12876.tar.xz
community/faenza-icon-theme: move from main
Diffstat (limited to 'community/faenza-icon-theme')
-rw-r--r--community/faenza-icon-theme/APKBUILD246
1 files changed, 246 insertions, 0 deletions
diff --git a/community/faenza-icon-theme/APKBUILD b/community/faenza-icon-theme/APKBUILD
new file mode 100644
index 0000000000..e2baa56135
--- /dev/null
+++ b/community/faenza-icon-theme/APKBUILD
@@ -0,0 +1,246 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=faenza-icon-theme
+pkgver=1.3.1
+pkgrel=4
+pkgdesc="icons designed to go in tandem with equinox themes"
+arch="noarch"
+url="http://tiheum.deviantart.com/art/Faenza-Icons-173323228"
+license="GPL"
+depends=
+makedepends=
+install=
+subpackages="$pkgname-extras
+
+ $pkgname-abiword
+ $pkgname-audacious
+ $pkgname-audacity
+ $pkgname-evince
+ $pkgname-firefox
+ $pkgname-geany
+ $pkgname-gimp
+ $pkgname-glade
+ $pkgname-gnome-panel:gnome_panel
+ $pkgname-gnome-session:gnome_session
+ $pkgname-gnumeric
+ $pkgname-gparted
+ $pkgname-hexchat
+ $pkgname-imagemagick
+ $pkgname-inkscape
+ $pkgname-libreoffice-calc:lo_calc
+ $pkgname-libreoffice-common:lo_common
+ $pkgname-libreoffice-draw:lo_draw
+ $pkgname-libreoffice-impress:lo_impress
+ $pkgname-libreoffice-main:lo_main
+ $pkgname-libreoffice-math:lo_math
+ $pkgname-libreoffice-writer:lo_writer
+ $pkgname-libreoffice
+ $pkgname-midori
+ $pkgname-mplayer
+ $pkgname-pidgin
+ $pkgname-shotwell
+ $pkgname-thunar
+ $pkgname-transmission
+ $pkgname-truecrypt
+ $pkgname-vim
+ $pkgname-vlc
+ $pkgname-wine
+ $pkgname-wireshark
+ $pkgname-xbmc
+ $pkgname-xchat
+ $pkgname-xfce4-appfinder:xfce4_appfinder
+ $pkgname-xfce4-panel:xfce4_panel
+
+ $pkgname-deadbeef
+ $pkgname-dia
+ $pkgname-emacs
+ $pkgname-evolution
+ $pkgname-hardinfo
+ $pkgname-thunderbird
+ $pkgname-totem
+ "
+
+
+source="https://launchpad.net/~tiheum/+archive/equinox/+files/faenza-icon-theme_$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-1.3
+
+package() {
+ cd "$_builddir" || return 1
+
+ mkdir -p "$pkgdir"/usr/share/icons
+ cp -dpRf Faenza* "$pkgdir"/usr/share/icons
+ find "$pkgdir"/usr/share/icons -name 'xchat*' | while read i; do
+ ln -s "${i##*/}" "${i/xchat/hexchat}" || break
+ done
+}
+
+_app() {
+ local app="$1" glob=
+ shift
+ pkgdesc="$pkgname - $app"
+ replaces="$pkgname"
+ if [ -n "$app" ]; then
+ install_if="$pkgname=$pkgver-r$pkgrel $app"
+ else
+ install_if=
+ fi
+ cd "$pkgdir"
+ for glob in "$@"; do
+ find . -name "$glob" | while read path; do
+ mkdir -p "$subpkgdir/${path%/*}"
+ mv "$pkgdir/$path" "$subpkgdir/$path" || return 1
+ done
+ done
+}
+
+abiword() { _app abiword 'abiword*'; }
+audacious() { _app audacious 'audacious*'; }
+audacity() { _app audacity 'audacity*'; }
+evince() { _app evince 'evince*'; }
+firefox() { _app firefox '*firefox*'; }
+geany() { _app geany 'geany*'; }
+gimp() { _app gimp 'gimp*'; }
+glade() { _app glade 'glade*'; }
+gnome_panel() { _app gnome-panel 'gnome-panel*'; }
+gnome_session() { _app gnome-session 'gnome-session*'; }
+gnumeric() { _app gnumeric 'gnumeric*'; }
+gparted() { _app gparted 'gparted*'; }
+hexchat() { depends="$pkgname-xchat"; _app hexchat 'hexchat*'; }
+imagemagick() { _app imagemagick 'imagemagick*'; }
+inkscape() { _app inkscape 'inkscape*'; }
+lo_base() { _app libreoffice-base 'libreoffice*-base*'; }
+lo_calc() { _app libreoffice-calc 'libreoffice*-calc*'; }
+lo_common() { _app libreoffice-common 'libreoffice*-startcenter*'; }
+lo_draw() { _app libreoffice-draw 'libreoffice*-draw*'; }
+lo_impress() { _app libreoffice-impress 'libreoffice*-impress*'; }
+lo_main() { _app libreoffice-main 'libreoffice*-main*'; }
+lo_math() { _app libreoffice-math 'libreoffice*-math*'; }
+lo_writer() { _app libreoffice-writer 'libreoffice*-writer*'; }
+libreoffice() { _app libreoffice 'libreoffice*'; }
+midori() { _app midori 'midori*'; }
+mplayer() { _app mplayer 'mplayer*'; }
+pidgin() { _app pidgin 'pidgin*'; }
+shotwell() { _app shotwell 'shotwell*'; }
+thunar() { _app thunar 'thunar*'; }
+transmission() { _app transmission 'transmission*'; }
+truecrypt() { _app truecrypt 'truecrypt*'; }
+vim() { _app vim 'vim*'; }
+vlc() { _app vlc 'vlc*'; }
+wine() { _app wine '*wine*'; }
+wireshark() { _app wireshark 'wireshark*'; }
+xbmc() { _app xbmc 'xbmc*'; }
+xchat() { _app xchat 'xchat*'; }
+xfce4_appfinder() { _app xfce4-appfinder 'xfce4-appfinder*'; }
+xfce4_panel() { _app xfce4-panel 'xfce4-panel*'; }
+
+# testing
+deadbeef() { _app deadbeef 'deadbeef*'; }
+dia() { _app dia 'dia*'; }
+emacs() { _app emacs 'emacs*'; }
+evolution() { _app evolution '*evolution*'; }
+hardinfo() { _app hardinfo 'hardinfo*'; }
+thunderbird() { _app thunderbird '*thunderbird*'; }
+totem() { _app totem 'totem*'; }
+
+
+#unsupported apps
+extras() { _app "" \
+ '*adobe*' \
+ '*chess*' \
+ '*crom*' \
+ '*ubuntu*' \
+ 'WorldOfGoo*' \
+ 'amue*' \
+ 'blender*' \
+ 'bluefish*' \
+ 'bluegriffon' \
+ 'brasero*' \
+ 'bug-buddy*' \
+ 'chromium-browser' \
+ 'clementine*' \
+ 'comix' \
+ 'computerjanitor*' \
+ 'desura*' \
+ 'docky*' \
+ 'dropbox*' \
+ 'eclipse*' \
+ 'emesene' \
+ 'emsene*' \
+ 'eog.*' \
+ 'exaile*' \
+ 'f-spot*' \
+ 'fedora*' \
+ 'filezilla' \
+ 'frostwire*' \
+ 'gajim*' \
+ 'gbrainy*' \
+ 'gcstar*' \
+ 'glippy*' \
+ 'gnome-activity' \
+ 'gnome-aisleriot' \
+ 'gnome-do*' \
+ 'gnome-freecell' \
+ 'gnome-glines' \
+ 'gnome-gnect*' \
+ 'gnome-gnibbles' \
+ 'gnome-iagno' \
+ 'gnome-klotski' \
+ 'gnome-lightsoff' \
+ 'gnome-mahjong*' \
+ 'gnome-mines*' \
+ 'gnome-mines*' \
+ 'gnome-quadrapassel' \
+ 'gnome-robots' \
+ 'gnome-samegnome' \
+ 'gnome-sudoku' \
+ 'gnome-swell-foop' \
+ 'gnome-tali*' \
+ 'gnome-tetravex' \
+ 'google-chrome' \
+ 'googleearth*' \
+ 'guayadeque*' \
+ 'gwibber*' \
+ 'haguichi*' \
+ 'homebank*' \
+ 'icedove' \
+ 'iceweasel' \
+ 'jdownloader' \
+ 'jockey*' \
+ 'library-internet-radio' \
+ 'logviewer' \
+ 'miro*' \
+ 'mono*' \
+ 'mypaint*' \
+ 'netbeans*' \
+ 'nvidia-settings*' \
+ 'ooo-*' \
+ 'ooo-*' \
+ 'openttd*' \
+ 'opera*' \
+ 'picasa*' \
+ 'pino*' \
+ 'pithos*' \
+ 'pitivi*' \
+ 'ppa.*' \
+ 'rhythmbox' \
+ 'rythmbox*' \
+ 'shutter*' \
+ 'skype*' \
+ 'softwarecenter-debian' \
+ 'spotify*' \
+ 'steam*' \
+ 'stellarium*' \
+ 'synapse*' \
+ 'telepathy*' \
+ 'tomboy*' \
+ 'tvtime*' \
+ 'wxbanker*' \
+ 'xine' \
+ 'xournal*' \
+
+}
+
+md5sums="b5339b70cbb821b583499e725957b150 faenza-icon-theme_1.3.1.tar.gz"
+sha256sums="afd1c32229989e4cf09733c1ce5f2a651e585d86f45e98e9de6e8813f15d0edc faenza-icon-theme_1.3.1.tar.gz"
+sha512sums="0c017ddbaa2dba485341d3bb1e321fafad026aafc893fa2519ddfd3fe0475fc8d011c99ce3de581c9b1c6aa7d250312673dda7c10bb12783db2d45816646ddc9 faenza-icon-theme_1.3.1.tar.gz"