aboutsummaryrefslogtreecommitdiffstats
path: root/community/fastjar
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-28 13:00:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-28 15:36:20 +0000
commitbee941037412f7cad59a6cbe9965568dc5052040 (patch)
tree4552e3b84fe87c877ed3592b7fe653c4f001895b /community/fastjar
parentf4c84a04891095dc4a9c45a7f717bbcefdc43716 (diff)
downloadaports-bee941037412f7cad59a6cbe9965568dc5052040.tar.bz2
aports-bee941037412f7cad59a6cbe9965568dc5052040.tar.xz
community/fastjar: move from main
Diffstat (limited to 'community/fastjar')
-rw-r--r--community/fastjar/0001-Properly-zero-terminate-filename.patch16
-rw-r--r--community/fastjar/0002-Fix-write-return-value-check.patch17
-rw-r--r--community/fastjar/APKBUILD52
3 files changed, 85 insertions, 0 deletions
diff --git a/community/fastjar/0001-Properly-zero-terminate-filename.patch b/community/fastjar/0001-Properly-zero-terminate-filename.patch
new file mode 100644
index 0000000000..ed510b09df
--- /dev/null
+++ b/community/fastjar/0001-Properly-zero-terminate-filename.patch
@@ -0,0 +1,16 @@
+http://cvs.savannah.gnu.org/viewvc/fastjar/jartool.c?root=fastjar&r1=1.59&r2=1.60&view=patch
+
+2010-03-01 Richard Guenther <rguenther@suse.de>
+
+ * jartool.c (read_entries): Properly zero-terminate filename.
+
+--- a/jartool.c 2009/09/06 22:16:00 1.59
++++ b/jartool.c 2010/03/01 15:38:43 1.60
+@@ -790,6 +790,7 @@
+ progname, jarfile);
+ return 1;
+ }
++ ze->filename[len] = '\0';
+ len = UNPACK_UB4(header, CEN_EFLEN);
+ len += UNPACK_UB4(header, CEN_COMLEN);
+ if (lseek (fd, len, SEEK_CUR) == -1)
diff --git a/community/fastjar/0002-Fix-write-return-value-check.patch b/community/fastjar/0002-Fix-write-return-value-check.patch
new file mode 100644
index 0000000000..e13f63ecca
--- /dev/null
+++ b/community/fastjar/0002-Fix-write-return-value-check.patch
@@ -0,0 +1,17 @@
+http://cvs.savannah.gnu.org/viewvc/fastjar/jartool.c?root=fastjar&r1=1.60&r2=1.61&view=patch
+
+2010-06-10 Chris Ball <cjb@laptop.org>
+
+ * jartool.c (add_file_to_jar): Fix write return value check.
+
+--- a/jartool.c 2010/03/01 15:38:43 1.60
++++ b/jartool.c 2010/06/10 08:46:10 1.61
+@@ -1258,7 +1258,7 @@
+ exit_on_error("write");
+
+ /* write the file name to the zip file */
+- if (1 == write(jfd, fname, file_name_length))
++ if (-1 == write(jfd, fname, file_name_length))
+ exit_on_error("write");
+
+ if(verbose){
diff --git a/community/fastjar/APKBUILD b/community/fastjar/APKBUILD
new file mode 100644
index 0000000000..fb52120439
--- /dev/null
+++ b/community/fastjar/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Timo Teras <timo.teras@iki.fi>
+# Maintainer: Timo Teras <timo.teras@iki.fi>
+pkgname=fastjar
+pkgver=0.98
+pkgrel=3
+pkgdesc="A fast implementation of Java Archiver"
+url="http://savannah.nongnu.org/projects/fastjar"
+arch="all"
+license="GPL-2.0"
+depends=
+makedepends="zlib-dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
+ 0001-Properly-zero-terminate-filename.patch
+ 0002-Fix-write-return-value-check.patch
+ "
+
+prepare() {
+ cd "$builddir"
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/usr/lib/charset.alias
+ rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
+}
+
+sha512sums="c0f9fca7b58d6acd00b90a5184dbde9ba3ffc5bf4d69512743e450649a272baf1f6af98b15d79d2b53990eaf84ef402c986035e6b615a19e35ed424348143903 fastjar-0.98.tar.gz
+0aa74753c008e20f009dc5f84fc9219668c1365b2c53012e32ed1b8cc216c4833d8d1af80af8eb9e138b0c7f4fcda207448ff57941184dbfe71f7d4cd08392ea 0001-Properly-zero-terminate-filename.patch
+f4ae60d70f2c547bebd6c3fc1baaa0e959de54c36a667b2c0d9526e87e5604fbef29b4ab20a4140306157b98528a16744a8b7dfb14ff4781fb2fe196b00665d8 0002-Fix-write-return-value-check.patch"