aboutsummaryrefslogtreecommitdiffstats
path: root/community/fdupes
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-03-01 03:12:40 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-03-01 03:12:40 +0000
commitddd426fbc807bf6750d3e4a2c4c8665708d77887 (patch)
tree130cdc5ee279cb11e35720ffb5ff464bba9b83ff /community/fdupes
parent0d8c66c18bd65863c3c8f3bed7fe48d251f123b0 (diff)
downloadaports-ddd426fbc807bf6750d3e4a2c4c8665708d77887.tar.bz2
aports-ddd426fbc807bf6750d3e4a2c4c8665708d77887.tar.xz
community/fdupes: move from testing
Diffstat (limited to 'community/fdupes')
-rw-r--r--community/fdupes/APKBUILD35
-rw-r--r--community/fdupes/overide-prefix.patch11
2 files changed, 46 insertions, 0 deletions
diff --git a/community/fdupes/APKBUILD b/community/fdupes/APKBUILD
new file mode 100644
index 0000000000..c8386f5a70
--- /dev/null
+++ b/community/fdupes/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=fdupes
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="identifying or deleting duplicate files residing within specified directories"
+url="https://github.com/adrianlopezroche/fdupes"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="fdupes-$pkgver.tar.gz::https://github.com/adrianlopezroche/fdupes/archive/v$pkgver.tar.gz
+ overide-prefix.patch
+ "
+builddir="$srcdir/fdupes-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}
+
+check() {
+ "$builddir"/fdupes --version &> /dev/null
+}
+
+sha512sums="6c6662b70068c2f48f4be64a6830c81a66852d650391d0756f20b9ac0df7d70c1a32918bd7cbd50e19de524d9ebc09ea338c19636e1807b071eb96b325e641db fdupes-1.6.1.tar.gz
+57685eabb2688f1e64ca8d61e54088ea8ad10820d15c2467f04e75cc0ee293dff68646a87055b028e81ddc0c6c7d3bef5724aef9f7ba2b6c8e45dfe472e52e3d overide-prefix.patch"
diff --git a/community/fdupes/overide-prefix.patch b/community/fdupes/overide-prefix.patch
new file mode 100644
index 0000000000..d08a3cf533
--- /dev/null
+++ b/community/fdupes/overide-prefix.patch
@@ -0,0 +1,11 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -11,7 +11,7 @@
+ # determination of the actual installation directories.
+ # Suggested values are "/usr/local", "/usr", "/pkgs/fdupes-$(VERSION)"
+ #
+-PREFIX = /usr/local
++PREFIX ?= /usr/local
+
+ #
+ # When compiling for 32-bit systems, FILEOFFSET_64BIT must be enabled