aboutsummaryrefslogtreecommitdiffstats
path: root/community/ffmpeg
diff options
context:
space:
mode:
authorMinecrell <minecrell@minecrell.net>2019-12-07 00:41:05 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-07 01:09:11 +0100
commitae7140f7ed94b846a452b553d5b57687cf836128 (patch)
treefc72833c82b0b4fdfc7f74f40a835d056477f397 /community/ffmpeg
parent674fe6740c948255ae62a6459cbb0482daf0d385 (diff)
downloadaports-ae7140f7ed94b846a452b553d5b57687cf836128.tar.bz2
aports-ae7140f7ed94b846a452b553d5b57687cf836128.tar.xz
community/ffmpeg: re-enable asm on arm*
FFmpeg is pretty much unusable with --disable-asm on arm*. At some point, ASM was disabled on arm* because FFmpeg required text relocations. That does no longer seem to be the case. The package builds just fine on arm* without --disable-asm (without triggering the textrels check) and everything runs much faster.
Diffstat (limited to 'community/ffmpeg')
-rw-r--r--community/ffmpeg/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/ffmpeg/APKBUILD b/community/ffmpeg/APKBUILD
index 0a7360bd55..9905fa0656 100644
--- a/community/ffmpeg/APKBUILD
+++ b/community/ffmpeg/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ffmpeg
pkgver=4.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="Complete and free Internet live audio and video broadcasting solution for Linux/Unix"
url="https://ffmpeg.org/"
arch="all"
@@ -80,7 +80,7 @@ build() {
[ -n "$DEBUG" ] && _dbg="--enable-debug"
case "$CARCH" in
- x86 | arm*) _asm="--disable-asm" ;;
+ x86) _asm="--disable-asm" ;;
esac
./configure \