aboutsummaryrefslogtreecommitdiffstats
path: root/community/filezilla/APKBUILD
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-04 13:15:49 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-04 13:15:49 +0000
commit2e65216018408e62ca55c451f3974f8b0aa75485 (patch)
treec54a1df0dcbff1348077ae9e2bbec2317a570768 /community/filezilla/APKBUILD
parentc67378f90a65ffb0aa0b57d91d0aa51c82715af5 (diff)
downloadaports-2e65216018408e62ca55c451f3974f8b0aa75485.tar.bz2
aports-2e65216018408e62ca55c451f3974f8b0aa75485.tar.xz
community/[lib]filezilla: move from testing
Diffstat (limited to 'community/filezilla/APKBUILD')
-rw-r--r--community/filezilla/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/filezilla/APKBUILD b/community/filezilla/APKBUILD
new file mode 100644
index 0000000000..dd6edb79fa
--- /dev/null
+++ b/community/filezilla/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=filezilla
+pkgver=3.34.0
+pkgrel=0
+pkgdesc="FTP Client"
+url="http://filezilla-project.org"
+arch="all"
+license="GPL-2.0"
+makedepends="libfilezilla-dev wxgtk-dev libidn-dev nettle-dev gnutls-dev
+ pugixml-dev xdg-utils gtk+2.0-dev sqlite-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://dl2.cdn.filezilla-project.org/client/FileZilla_${pkgver}_src.tar.bz2"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --without-dbus
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+sha512sums="577118bd053c3aedbe77082b138c30abc6a759b20ea905abc4e9bef965cbca3cf73023186c389ded7d906b7cf76e4f3d4462c00fae62c7b1ae695ad171c88764 FileZilla_3.34.0_src.tar.bz2"