aboutsummaryrefslogtreecommitdiffstats
path: root/community/flawfinder
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2018-12-14 20:18:07 +0100
committerHenrik Riomar <henrik.riomar@gmail.com>2018-12-14 20:18:07 +0100
commit350bd99f95f6dd14c44107ebb719433aa4d4f653 (patch)
tree749b6ff82a0f263092f043c5dc3e56a81f7c0d70 /community/flawfinder
parent99400e94de4d3edfc7a07e05a09798a6a190d895 (diff)
downloadaports-350bd99f95f6dd14c44107ebb719433aa4d4f653.tar.bz2
aports-350bd99f95f6dd14c44107ebb719433aa4d4f653.tar.xz
community/flawfinder: move from testing
Diffstat (limited to 'community/flawfinder')
-rw-r--r--community/flawfinder/APKBUILD35
-rw-r--r--community/flawfinder/use-python3.patch22
2 files changed, 57 insertions, 0 deletions
diff --git a/community/flawfinder/APKBUILD b/community/flawfinder/APKBUILD
new file mode 100644
index 0000000000..75a1b1f28d
--- /dev/null
+++ b/community/flawfinder/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=flawfinder
+pkgver=2.0.7
+pkgrel=0
+pkgdesc="Examines C/C++ source code for security flaws"
+url="http://www.dwheeler.com/flawfinder/"
+arch="noarch"
+license="GPL-2.0"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+subpackages="$pkgname-doc"
+source="http://www.dwheeler.com/flawfinder/$pkgname-$pkgver.tar.gz
+ use-python3.patch
+ "
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ecfe98c58e253b1d90b833747d69c41597ab7b4c82286e5f45dff45de90056216c25d2c9626540aebfc1e475882a04c3cfa3c0cb3ee242f498f5cdfe188d761f flawfinder-2.0.7.tar.gz
+aef3c9fc285255903e3b244bd76f99c7a7fe3c391f2d6a274ff7d1ea6dc38be82c9b537f3518c6cc600d5b3d5f60f1ed3b69aeaefc13246f9d908066273148ce use-python3.patch"
diff --git a/community/flawfinder/use-python3.patch b/community/flawfinder/use-python3.patch
new file mode 100644
index 0000000000..1b3a5d8a35
--- /dev/null
+++ b/community/flawfinder/use-python3.patch
@@ -0,0 +1,22 @@
+--- flawfinder-2.0.7/makefile
++++ flawfinder-2.0.7-use-python3/makefile
+@@ -12,8 +12,7 @@
+ ARCH=noarch
+
+ SAMPLE_DIR=/usr/src/linux-2.2.16
+-PYTHON=python
+-PYTHON2=python2
++PYTHON=python3
+ PYTHON3=python3
+
+ # Flawfinder has traditionally used INSTALL_DIR, INSTALL_DIR_BIN, and
+@@ -190,9 +189,6 @@
+
+ # Usual check routine. Run all tests using *both* python2 and python3.
+ check:
+- @echo "Testing with $(PYTHON2)"
+- @PYTHON="$(PYTHON2)" $(MAKE) test
+- @echo
+ @echo "Testing with $(PYTHON3)"
+ @PYTHON="$(PYTHON3)" $(MAKE) test
+