aboutsummaryrefslogtreecommitdiffstats
path: root/community/flickcurl
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-06-16 20:08:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-06-17 04:46:29 +0000
commit85e967c3713b591169b505d32bf7b9c1484f9b3b (patch)
treee89d0d7804885b5b24b74e0a1a04286df898b129 /community/flickcurl
parenteb94e6d03d6288abb5adc3fc27c669bab6eb33df (diff)
downloadaports-85e967c3713b591169b505d32bf7b9c1484f9b3b.tar.bz2
aports-85e967c3713b591169b505d32bf7b9c1484f9b3b.tar.xz
flickcurl: move to comminuty
Diffstat (limited to 'community/flickcurl')
-rw-r--r--community/flickcurl/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/flickcurl/APKBUILD b/community/flickcurl/APKBUILD
new file mode 100644
index 0000000000..356242e889
--- /dev/null
+++ b/community/flickcurl/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Kevin Daudt <ops@ikke.info>
+# Maintainer: Kevin Daudt <ops@ikke.info>
+pkgname=flickcurl
+pkgver=1.26
+pkgrel=0
+pkgdesc="C library for the Flickr API"
+url="http://librdf.org/flickcurl/"
+arch="all"
+license="GPL-2.0"
+makedepends="curl-dev libxml2-dev raptor2-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://download.dajobe.org/flickcurl/flickcurl-$pkgver.tar.gz"
+builddir="$srcdir/flickcurl-$pkgver"
+
+prepare() {
+ cd "$builddir"
+ update_config_guess || return 1
+ default_prepare || return 1
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix /usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="7013a36656400dac398748a374c9104f flickcurl-1.26.tar.gz"
+sha256sums="ff42a36c7c1c7d368246f6bc9b7d792ed298348e5f0f5d432e49f6803562f5a3 flickcurl-1.26.tar.gz"
+sha512sums="5ffdef58e67cbf99da2e8eefad57e845627703d5b22c85d5635557cd2df53e47e74d8e3387523495708c5cc8952c290da5c4d5f1e86bd482312fc7e46e9af6cd flickcurl-1.26.tar.gz"