aboutsummaryrefslogtreecommitdiffstats
path: root/community/fmt
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-03 03:37:38 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-03 12:13:04 +0100
commitdd8a947d2130b90fc7fb0b2d15cc2153a8393224 (patch)
treeac68c4ce49d763aed801e921c0e622a3f91ce27b /community/fmt
parent745cc20bad70b72ff599c06b3087e73a7d6fa462 (diff)
downloadaports-dd8a947d2130b90fc7fb0b2d15cc2153a8393224.tar.bz2
aports-dd8a947d2130b90fc7fb0b2d15cc2153a8393224.tar.xz
community/fmt: upgrade to 6.1.0
Diffstat (limited to 'community/fmt')
-rw-r--r--community/fmt/APKBUILD9
-rw-r--r--community/fmt/FMT_API.patch13
2 files changed, 19 insertions, 3 deletions
diff --git a/community/fmt/APKBUILD b/community/fmt/APKBUILD
index 77e80423b9..73d4017fda 100644
--- a/community/fmt/APKBUILD
+++ b/community/fmt/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Luca Weiss <luca@z3ntu.xyz>
# Maintainer: Luca Weiss <luca@z3ntu.xyz>
pkgname="fmt"
-pkgver="6.0.0"
+pkgver="6.1.0"
pkgrel=0
pkgdesc="Open-source formatting library for C++"
url="https://fmt.dev/latest/index.html"
@@ -9,7 +9,9 @@ arch="all"
license="MIT"
makedepends="cmake doxygen"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/fmtlib/fmt/releases/download/$pkgver/fmt-$pkgver.zip"
+source="https://github.com/fmtlib/fmt/releases/download/$pkgver/fmt-$pkgver.zip
+ FMT_API.patch
+ "
options="!check" # 93% tests passed, 1 tests failed out of 14
build() {
@@ -34,4 +36,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="c2d458c341ded52c3df0ce4ad45e2acc4d486200e97feb53d08de7802c44ec2e0284dde2beccc27db72fdd7bd9f06413c977dc3de7184250d6853222a750bcc7 fmt-6.0.0.zip"
+sha512sums="b6836bc47fb30317ab72f03929b98473d71ee01cbde677dd3a7646c1ee307d20951f027002dc3b04babe1b20c37b4cf4af056d47a4a9707e24379dc781be1cb5 fmt-6.1.0.zip
+387e1a11b1a4e668251f36aba07d002b9344755afff54eaaaaffae5f4f8eab093182310cf87b739c55f0a6ee9edca9a848fb7f14109a6d63e33d30249d3b46bc FMT_API.patch"
diff --git a/community/fmt/FMT_API.patch b/community/fmt/FMT_API.patch
new file mode 100644
index 0000000000..20e2533de5
--- /dev/null
+++ b/community/fmt/FMT_API.patch
@@ -0,0 +1,13 @@
+diff --git a/include/fmt/core.h b/include/fmt/core.h
+index 6a0846f..39d3e0e 100644
+--- a/include/fmt/core.h
++++ b/include/fmt/core.h
+@@ -224,7 +224,7 @@ namespace internal {
+ // A workaround for gcc 4.8 to make void_t work in a SFINAE context.
+ template <typename... Ts> struct void_t_impl { using type = void; };
+
+-void assert_fail(const char* file, int line, const char* message);
++FMT_API void assert_fail(const char* file, int line, const char* message);
+
+ #ifndef FMT_ASSERT
+ # ifdef NDEBUG