aboutsummaryrefslogtreecommitdiffstats
path: root/community/font-noto-cjk
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-03-02 21:27:47 -0700
committerLeo <thinkabit.ukim@gmail.com>2019-07-08 18:07:09 -0300
commitbd62c6576bf5d1d38ce59bc91a709e07b15e4355 (patch)
treecc7fc46fce241242372f1cf66bfca467628d339e /community/font-noto-cjk
parent006b422067bb7daf54e3281ac6268e821d26131c (diff)
downloadaports-bd62c6576bf5d1d38ce59bc91a709e07b15e4355.tar.bz2
aports-bd62c6576bf5d1d38ce59bc91a709e07b15e4355.tar.xz
community/font-noto-cjk: new APKBUILD
This is simplified from community/font-noto, but since they're versioned and distributed separately I made a separate APKBUILD.
Diffstat (limited to 'community/font-noto-cjk')
-rw-r--r--community/font-noto-cjk/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/font-noto-cjk/APKBUILD b/community/font-noto-cjk/APKBUILD
new file mode 100644
index 0000000000..5cb7723a16
--- /dev/null
+++ b/community/font-noto-cjk/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=font-noto-cjk
+pkgver=0_git20181130
+_sha=9326451d9b4f32ec7f8640581c5053cc192039f2
+pkgrel=0
+pkgdesc="Google's font family that aims to support all the world's languages (cjk)"
+url="https://github.com/googlei18n/noto-fonts/"
+arch="noarch"
+license="OFL-1.1"
+depends="fontconfig"
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/googlei18n/noto-cjk/archive/$_sha.tar.gz"
+builddir="$srcdir/noto-cjk-$_sha"
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/fonts/noto
+ install -m644 "$builddir"/*.otf \
+ "$pkgdir"/usr/share/fonts/noto/
+}
+
+sha512sums="d4578421919d03ecf82627375cfc4b227825af485140b35e2315d17f8ef38d034e0ffdd21fb3aa226c82e9cf587123867d565f93d32f8bf7d754571f0ebf825e font-noto-cjk-0_git20181130.tar.gz"