aboutsummaryrefslogtreecommitdiffstats
path: root/community/fossil/APKBUILD
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-07-13 23:39:02 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-07-25 17:48:28 -0300
commitcc237b8bfa2c8dbb4996134d69cb7df379166129 (patch)
treea7ec32fd8d942d024c416bbb6dad0c16e3773a3d /community/fossil/APKBUILD
parent7f1d9725f6b2ea424b7e26e393039ba21e44c6b0 (diff)
downloadaports-cc237b8bfa2c8dbb4996134d69cb7df379166129.tar.bz2
aports-cc237b8bfa2c8dbb4996134d69cb7df379166129.tar.xz
community/fossil: use upstream name variable
Diffstat (limited to 'community/fossil/APKBUILD')
-rw-r--r--community/fossil/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/fossil/APKBUILD b/community/fossil/APKBUILD
index 5d27810988..8f75d080c1 100644
--- a/community/fossil/APKBUILD
+++ b/community/fossil/APKBUILD
@@ -1,7 +1,8 @@
# Contributor: Paul Onyschuk <blink@bojary.koba.pl>
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: tcely <fossil+aports@tcely.33mail.com>
-pkgname="fossil"
+_pkgname="fossil" # upstream name
+pkgname="${_pkgname}"
pkgver="2.9"
pkgrel=0
pkgdesc="Simple, high-reliability, distributed software configuration management"
@@ -12,7 +13,8 @@ options="!check" # missing tcl modules
depends=""
checkdepends="coreutils ed tcllib"
makedepends="openssl-dev sqlite-dev tcl-dev zlib-dev"
-source="https://www.fossil-scm.org/index.html/uv/${pkgname}-src-${pkgver}.tar.gz"
+source="https://www.fossil-scm.org/index.html/uv/${_pkgname}-src-${pkgver}.tar.gz"
+builddir="${srcdir}/${_pkgname}-${pkgver}"
build() {
./configure \
@@ -29,7 +31,7 @@ check() {
}
package() {
- install -Dm 755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
}
sha512sums="c3786d4ae5517c88917819448863e9e1e37704a7073a1c87c042660313b77ce3a63f32e35e6a56af1c681e7b8a5acc652b4447d0387b8a8a5b3b5aa04dd9a9b5 fossil-src-2.9.tar.gz"