aboutsummaryrefslogtreecommitdiffstats
path: root/community/fossil/APKBUILD
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-04-08 14:40:16 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-08 18:45:22 +0000
commitf732d5983b34e7a557ccc8fe1fe2817f9953dd71 (patch)
tree51f32a9cd31e205bcf4e25d8d35161d304e08a1e /community/fossil/APKBUILD
parent9169af8621085bb76817994b5f0591094fd62525 (diff)
downloadaports-f732d5983b34e7a557ccc8fe1fe2817f9953dd71.tar.bz2
aports-f732d5983b34e7a557ccc8fe1fe2817f9953dd71.tar.xz
community/fossil: move from main
Diffstat (limited to 'community/fossil/APKBUILD')
-rw-r--r--community/fossil/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/community/fossil/APKBUILD b/community/fossil/APKBUILD
new file mode 100644
index 0000000000..23b997de01
--- /dev/null
+++ b/community/fossil/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Paul Onyschuk <blink@bojary.koba.pl>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: tcely <fossil+aports@tcely.33mail.com>
+pkgname=fossil
+pkgver=2.8
+pkgrel=0
+pkgdesc="Simple, high-reliability, distributed software configuration management"
+url="https://www.fossil-scm.org"
+arch="all"
+license="BSD-2-Clause"
+options="!check" # missing tcl modules
+depends=""
+# add tcllib when it is packaged
+checkdepends="coreutils ed"
+makedepends="openssl-dev sqlite-dev tcl-dev zlib-dev"
+source="https://www.fossil-scm.org/index.html/uv/$pkgname-src-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --json \
+ --disable-internal-sqlite
+ make TCC="${CC:-gcc} $CFLAGS"
+}
+
+check() {
+ cd "$builddir"
+ make TESTFLAGS="-quiet -halt" test
+}
+
+package() {
+ cd "$builddir"
+ install -Dm 755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}
+
+sha512sums="5c6a8dc1545c43b3c95fbbec343db023e27a9db58f282a881bb7e488e3e26a0f7913a41f505dedf618b884507e48956780bd0e12482e184345d68edd1e79ff8e fossil-src-2.8.tar.gz"