aboutsummaryrefslogtreecommitdiffstats
path: root/community/fractal
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-09-26 13:14:53 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-27 18:23:19 +0200
commitf0d8d6c7e0ef52e01a2e9ec4bd189d808fe6c50e (patch)
tree8149644e1b6e3f029b441a60eaaaf76cfa3ffc84 /community/fractal
parentd23e09480994846d6356ca2f12ddf9ca613f92d2 (diff)
downloadaports-f0d8d6c7e0ef52e01a2e9ec4bd189d808fe6c50e.tar.bz2
aports-f0d8d6c7e0ef52e01a2e9ec4bd189d808fe6c50e.tar.xz
community/fractal: enable on x86
Diffstat (limited to 'community/fractal')
-rw-r--r--community/fractal/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/community/fractal/APKBUILD b/community/fractal/APKBUILD
index 2539df41e5..72fc9ac44a 100644
--- a/community/fractal/APKBUILD
+++ b/community/fractal/APKBUILD
@@ -5,7 +5,7 @@ pkgver=4.2.1
pkgrel=0
pkgdesc="Matrix group messaging app"
url="https://wiki.gnome.org/Apps/Fractal"
-arch="x86_64 armhf armv7 aarch64 ppc64le" # limited by Rust
+arch="x86_64 x86 armhf armv7 aarch64 ppc64le" # limited by Rust
license="GPL-3.0-or-later"
makedepends="meson gtk+3.0-dev dbus-dev openssl-dev gspell-dev libhandy-dev
gtksourceview4-dev gstreamer-dev gst-plugins-base-dev gst-plugins-bad-dev
@@ -14,6 +14,12 @@ options="!check" # no tests
subpackages="$pkgname-lang"
source="https://gitlab.gnome.org/GNOME/fractal/-/archive/$pkgver/fractal-$pkgver.tar.gz"
+case "$CARCH" in
+ x86)
+ export CFLAGS="$CFLAGS -fno-stack-protector"
+ ;;
+esac
+
build() {
meson \
--prefix=/usr \