aboutsummaryrefslogtreecommitdiffstats
path: root/community/fstrcmp
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-07-31 00:45:50 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-31 05:33:43 -0300
commit580b6773bf3ab104942be5bf3528067e0627a9ba (patch)
tree2dfe9d43bfc1080d9cfc787747cb20a03efef380 /community/fstrcmp
parentdcb7fe02de7d82792f48857b64a8de54f86b566b (diff)
downloadaports-580b6773bf3ab104942be5bf3528067e0627a9ba.tar.bz2
aports-580b6773bf3ab104942be5bf3528067e0627a9ba.tar.xz
community/fstrcmp: move from testing
Required for Kodi in community
Diffstat (limited to 'community/fstrcmp')
-rw-r--r--community/fstrcmp/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/fstrcmp/APKBUILD b/community/fstrcmp/APKBUILD
new file mode 100644
index 0000000000..0b0c260789
--- /dev/null
+++ b/community/fstrcmp/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=fstrcmp
+pkgver=0.7
+pkgrel=0
+arch="all"
+url="http://fstrcmp.sourceforge.net/"
+pkgdesc="Make fuzzy comparisons of strings and byte arrays"
+license="GPL-3.0-or-later"
+makedepends="libtool ghostscript groff"
+source="$pkgname-$pkgver.tar.gz::http://fstrcmp.sourceforge.net/$pkgname-$pkgver.D001.tar.gz"
+subpackages="$pkgname-static $pkgname-dev $pkgname-doc"
+builddir="$srcdir/$pkgname-$pkgver.D001"
+
+build() {
+ ./configure \
+ --prefix=/usr
+ make
+}
+
+check() {
+ make test
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="aaeb0227afd5ada5955cbe6a565254ff88d2028d677d199c00e03b7cb5de1f2c69b18e6e8b032e452350a8eda7081807b01765adbeb8476eaf803d9de6e5509c fstrcmp-0.7.tar.gz"