aboutsummaryrefslogtreecommitdiffstats
path: root/community/fwup
diff options
context:
space:
mode:
authorFrank Hunleth <fhunleth@troodon-software.com>2018-08-15 00:51:44 -0400
committerAndy Postnikov <apostnikov@gmail.com>2018-08-15 19:17:14 +0300
commit17a762b90e4a61af8d26f240f4e61da7dda39615 (patch)
treebe0a22dc47310deb14925939e1b1e0afa0595ced /community/fwup
parent75135959887105b26f2b6d70b81ecfff956e01ef (diff)
downloadaports-17a762b90e4a61af8d26f240f4e61da7dda39615.tar.bz2
aports-17a762b90e4a61af8d26f240f4e61da7dda39615.tar.xz
testing/fwup: move to community
Diffstat (limited to 'community/fwup')
-rw-r--r--community/fwup/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/fwup/APKBUILD b/community/fwup/APKBUILD
new file mode 100644
index 0000000000..5c231450ff
--- /dev/null
+++ b/community/fwup/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Frank Hunleth <fhunleth@troodon-software.com>
+# Maintainer: Frank Hunleth <fhunleth@troodon-software.com>
+pkgname=fwup
+pkgver=1.2.5
+pkgrel=0
+pkgdesc="Configurable embedded Linux firmware update creator and runner"
+url="https://github.com/fhunleth/fwup"
+arch="all"
+license="Apache-2.0"
+makedepends="linux-headers confuse-dev libarchive-dev libsodium-dev help2man dosfstools mtools zip unzip"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/fhunleth/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="63d3fd905259059933cf12753801863255840db0ad62463e0adb37b3beaa2f66d7f055d8e6a713e1392fe08c4007e72facd374859c6dd007437382568bbc7c3c fwup-1.2.5.tar.gz"