aboutsummaryrefslogtreecommitdiffstats
path: root/community/fwup
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-08 00:29:08 -0300
committerAndy Postnikov <apostnikov@gmail.com>2019-05-09 04:03:18 +0300
commit8d7d6fa88d31c978e8ee4530619363db1083a608 (patch)
tree46bcb5668bba6a2e22556d26125fcc0a277089b1 /community/fwup
parent536fa657b90f60a26edf4aca121138a10dda609f (diff)
downloadaports-8d7d6fa88d31c978e8ee4530619363db1083a608.tar.bz2
aports-8d7d6fa88d31c978e8ee4530619363db1083a608.tar.xz
community/fwup: upgrade to 1.3.1
Diffstat (limited to 'community/fwup')
-rw-r--r--community/fwup/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/community/fwup/APKBUILD b/community/fwup/APKBUILD
index 40edd38e31..a876485932 100644
--- a/community/fwup/APKBUILD
+++ b/community/fwup/APKBUILD
@@ -1,19 +1,17 @@
# Contributor: Frank Hunleth <fhunleth@troodon-software.com>
# Maintainer: Frank Hunleth <fhunleth@troodon-software.com>
pkgname=fwup
-pkgver=1.3.0
+pkgver=1.3.1
pkgrel=0
pkgdesc="Configurable embedded Linux firmware update creator and runner"
url="https://github.com/fhunleth/fwup"
arch="all"
license="Apache-2.0"
makedepends="linux-headers confuse-dev libarchive-dev libsodium-dev help2man dosfstools mtools zip unzip"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
source="$pkgname-$pkgver.tar.gz::https://github.com/fhunleth/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,13 +23,21 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="45bdb6b66ec4e10f4ed1e9b94ebc22c7976040f2594942b804f44fa018606a344914de5aa0318685e99221ceea8942eafc354f68b39d2529208767949a3cb458 fwup-1.3.0.tar.gz"
+bashcomp() {
+ depends=""
+ pkgdesc="Bash completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
+ mv "$pkgdir"/usr/share/bash-completion/completions/* \
+ "$subpkgdir"/usr/share/bash-completion/completions
+}
+
+sha512sums="c1d97d7973eb45bbe5acf606dc49d5ceac44f2f3e5176a3fbf3cfc67f42ad9dfb50c299d5167bde3555f5fdf5640857335eec048763aa2859139a33aa36b270e fwup-1.3.1.tar.gz"