aboutsummaryrefslogtreecommitdiffstats
path: root/community/fzf/APKBUILD
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-04-02 18:08:34 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-02 19:55:30 +0000
commitfabcb1e01382b67a1ed3527c8eafa061f5136bd5 (patch)
tree3461837fdf09894c461f8b4ffb4ab2fbfdc09116 /community/fzf/APKBUILD
parentc3c4514c5db9d9ba899e8d0779906e5dbe714825 (diff)
downloadaports-fabcb1e01382b67a1ed3527c8eafa061f5136bd5.tar.bz2
aports-fabcb1e01382b67a1ed3527c8eafa061f5136bd5.tar.xz
community/fzf: update to 0.18.0
fzf no longer provides a glide file itself, so we now need to supply our own.
Diffstat (limited to 'community/fzf/APKBUILD')
-rw-r--r--community/fzf/APKBUILD36
1 files changed, 28 insertions, 8 deletions
diff --git a/community/fzf/APKBUILD b/community/fzf/APKBUILD
index 087a84ed17..055cb499bb 100644
--- a/community/fzf/APKBUILD
+++ b/community/fzf/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=fzf
-pkgver=0.17.5
-pkgrel=2
+pkgver=0.18.0
+pkgrel=0
pkgdesc="A command-line fuzzy finder"
url="https://github.com/junegunn/fzf"
arch="all !s390x !aarch64 !armhf !armv7"
@@ -14,13 +14,21 @@ subpackages="
$pkgname-zsh-completion:zshcomp:noarch
"
source="$pkgname-$pkgver.tar.gz::https://github.com/junegunn/fzf/archive/$pkgver.tar.gz
- no-glide-install.patch"
+ glide.yaml
+ glide.lock"
+builddir="$srcdir/src/github.com/junegunn/$pkgname"
prepare() {
- default_prepare
+ export GOPATH="$srcdir"
+
+ mkdir -p "$(dirname "$builddir")"
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+
cd "$builddir"
- export GOPATH="$startdir"
- glide install
+ cp "$srcdir"/glide.yaml "$srcdir"/glide.lock .
+ glide install --skip-test
+
+ default_prepare
}
build() {
@@ -71,5 +79,17 @@ zshcomp() {
install -m0644 shell/key-bindings.zsh "$subpkgdir"/usr/share/fzf/
}
-sha512sums="adb5290317362c32d053294a2dd9a2aa11711521635c1cb1fc11001dea1b06e27856a7c54e7316d211abee3304cc56b8a9ee60773bb99cb4132b533f5464a430 fzf-0.17.5.tar.gz
-daa16985079e3b55ccf5e74dde356e1e13e43865c9809e432b5d272b053f541f1eacd402f3b04957ee855fb8c0ca1820b507d08e408f55dc80004990a949874c no-glide-install.patch"
+glide_init() {
+ abuild clean deps unpack prepare
+ cd "$builddir"
+ export GOPATH="$startdir"
+ rm -f glide.yaml glide.lock
+ glide init --non-interactive
+ glide update
+ cp glide.yaml glide.lock "$startdir"
+ cd "$startdir" && abuild checksum clean
+}
+
+sha512sums="70dcda693ed6706f232874550f89cfcdbce1d28360244a728dd0640a4cfbbbd0899601f42c9096197c159cde86e89d287a06905cb5d665bd09b9d01cca2cb754 fzf-0.18.0.tar.gz
+dc14dea17ea585344e16eeffdc244693d97f4519676d20ec43434f6eff460d61be833399469ccb44c25c9fed296d52d424208c4a4cae5a3beecba14593cecd49 glide.yaml
+5d1c0801d79a0425e1ec02c818bf440f2201841f356f32350fac06bf3ed7a7d03c0718cbeadc07143701895152f7ee19919e6e527be9e17c0df430f93d0282c9 glide.lock"