aboutsummaryrefslogtreecommitdiffstats
path: root/community/fzf/disable-vet-for-tests.patch
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-03-11 16:10:15 +0000
committerSören Tempel <soeren+git@soeren-tempel.net>2018-03-11 21:16:50 +0100
commitd5cfcd38e93d52bef507fb0dd397f11e7a5c9f40 (patch)
tree639b36876647896b520ab8807dd6c359a625c0f0 /community/fzf/disable-vet-for-tests.patch
parent2a0a045ee30960703a3713a73b6f3601f06e1cfa (diff)
downloadaports-d5cfcd38e93d52bef507fb0dd397f11e7a5c9f40.tar.bz2
aports-d5cfcd38e93d52bef507fb0dd397f11e7a5c9f40.tar.xz
community/fzf: disable vetting in tests
Since Go 1.10, they enabled vetting by default when running tests. This reveals issues in the thests which should be fixed upstream, but for now, disable vetting to let the tests pass again. An upstream issue[0] has been created. Untill then, apply a patch to the Makefile to disable vetting. [0]: https://github.com/junegunn/fzf/issues/1236
Diffstat (limited to 'community/fzf/disable-vet-for-tests.patch')
-rw-r--r--community/fzf/disable-vet-for-tests.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/fzf/disable-vet-for-tests.patch b/community/fzf/disable-vet-for-tests.patch
new file mode 100644
index 0000000000..328b80277e
--- /dev/null
+++ b/community/fzf/disable-vet-for-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 5f68100828..123bfe9974 100644
+--- a/Makefile
++++ b/Makefile
+@@ -102,7 +102,7 @@ vendor: $(GLIDE_YAML)
+ touch $@
+
+ test: $(SOURCES) vendor
+- SHELL=/bin/sh GOOS= go test -v -tags "$(TAGS)" \
++ SHELL=/bin/sh GOOS= go test -v -tags "$(TAGS)" -vet=off \
+ github.com/junegunn/fzf/src \
+ github.com/junegunn/fzf/src/algo \
+ github.com/junegunn/fzf/src/tui \