aboutsummaryrefslogtreecommitdiffstats
path: root/community/gdnsd/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-14 15:29:13 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-14 15:29:13 -0300
commitb5a69b97f9d03109eb8fbf12140905c96ceecbbd (patch)
tree74ed031e1464aa43b215682810e80fabe5f471f1 /community/gdnsd/APKBUILD
parentd6a4eaf6ca65401689aa4765cf3c2042a3fcd89d (diff)
downloadaports-b5a69b97f9d03109eb8fbf12140905c96ceecbbd.tar.bz2
aports-b5a69b97f9d03109eb8fbf12140905c96ceecbbd.tar.xz
community/*: remove invalid options and modernize
Diffstat (limited to 'community/gdnsd/APKBUILD')
-rw-r--r--community/gdnsd/APKBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/community/gdnsd/APKBUILD b/community/gdnsd/APKBUILD
index 54900b757a..394c4e6212 100644
--- a/community/gdnsd/APKBUILD
+++ b/community/gdnsd/APKBUILD
@@ -2,22 +2,18 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=gdnsd
pkgver=2.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Geographic Authoritative DNS server"
url="https://github.com/blblack/gdnsd/"
arch="all"
-license="GPL-3.0"
-depends=""
-depends_dev=""
-options="!checkroot"
+license="GPL-3.0-or-later"
makedepends="userspace-rcu-dev libev-dev libcap-dev libmaxminddb-dev ragel autoconf automake libtool"
checkdepends="perl perl-libwww perl-socket6 perl-io-socket-inet6 perl-http-daemon perl-test-harness perl-test-harness-utils"
install="$pkgname.pre-install"
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/gdnsd/gdnsd/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz
+source="https://github.com/gdnsd/gdnsd/releases/download/v$pkgver/gdnsd-$pkgver.tar.xz
gdnsd.initd"
-builddir="$srcdir"/gdnsd-$pkgver
prepare() {
default_prepare
@@ -25,7 +21,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -37,15 +32,12 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
- install -Dm755 "$srcdir"/gdnsd.initd \
- "$pkgdir"/etc/init.d/gdnsd
+ install -Dm755 "$srcdir"/gdnsd.initd "$pkgdir"/etc/init.d/gdnsd
}
sha512sums="be7a93901283abe0c4304456263d75b81e3a4141be37c4eaa0149e757dca60cef26a926a6134f6e3ef67da5be70bfd3be78f37a8b3788c75e81f421ae744de53 gdnsd-2.4.0.tar.xz