aboutsummaryrefslogtreecommitdiffstats
path: root/community/geany-plugins
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 20:22:08 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 21:21:31 -0300
commit29a19cc9b3da8422effde6cc74ce892dcf41c7ed (patch)
tree40a7341a0af44fafcb329a7023d6ad229aa99e74 /community/geany-plugins
parent21f440daa5c0077806cbb2e99daadd159294de30 (diff)
downloadaports-29a19cc9b3da8422effde6cc74ce892dcf41c7ed.tar.bz2
aports-29a19cc9b3da8422effde6cc74ce892dcf41c7ed.tar.xz
community/geany-plugins: use python3 for geanypy
Diffstat (limited to 'community/geany-plugins')
-rw-r--r--community/geany-plugins/APKBUILD32
1 files changed, 8 insertions, 24 deletions
diff --git a/community/geany-plugins/APKBUILD b/community/geany-plugins/APKBUILD
index 7dc1265116..42dcdcb1e5 100644
--- a/community/geany-plugins/APKBUILD
+++ b/community/geany-plugins/APKBUILD
@@ -2,15 +2,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=geany-plugins
pkgver=1.35
-pkgrel=0
+pkgrel=1
pkgdesc="Plugins for Geany"
url="https://plugins.geany.org/"
arch="all"
license="GPL-3.0-or-later"
-depends=""
makedepends="lua-dev geany-dev enchant-dev intltool gtkspell-dev libxml2-dev
- bash vte-dev vala libsoup-dev gpgme-dev python2-dev py-gtk-dev"
-install=""
+ bash vte-dev vala libsoup-dev gpgme-dev python3-dev"
subpackages="$pkgname-dev $pkgname-doc
$pkgname-addons
$pkgname-autoclose
@@ -53,35 +51,21 @@ subpackages="$pkgname-dev $pkgname-doc
$pkgname-lang
"
-source="https://plugins.geany.org/$pkgname/$pkgname-$pkgver.tar.bz2"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="https://plugins.geany.org/geany-plugins/geany-plugins-$pkgver.tar.bz2"
build() {
- cd "$_builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--with-lua-pkg=lua \
- --disable-debugger \
- || return 1
- make || return 1
+ --disable-debugger
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
utils() {
@@ -95,7 +79,7 @@ _plugin() {
pkgdesc="$2"
local _d
mkdir -p "$subpkgdir"/usr/lib/geany
- mv "$pkgdir"/usr/lib/geany/$1.so "$subpkgdir"/usr/lib/geany/ || return 1
+ mv "$pkgdir"/usr/lib/geany/$1.so "$subpkgdir"/usr/lib/geany/
cd "$pkgdir"
for _d in usr/*/geany-plugins/$1; do
if [ -d "$_d" ]; then
@@ -122,7 +106,7 @@ geanymacro() { _plugin geanymacro "User defined Macros for Geany"; }
geanyminiscript() { _plugin geanyminiscript "Geany Mini-Script filter plugin"; }
geanynumberedbookmarks() { _plugin geanynumberedbookmarks "Provide users 10 numbered Bookmarks"; }
geanypg() { _plugin geanypg "A plugin for Geany that allows the user to encrypt, decrypt and verify signatures with GnuPG"; }
-geanypy() { _plugin geanypy "Provides Python bindings for Geany";
+geanypy() { _plugin geanypy "Provides Python3 bindings for Geany";
# Currently missing. Requires GTK+2.0
mv "$pkgdir"/usr/lib/geany/geanypy \
"$pkgdir"/usr/lib/geany/*.py \