aboutsummaryrefslogtreecommitdiffstats
path: root/community/gegl
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-04-08 12:13:29 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-11 12:13:22 +0000
commit9f33a51efabc9d3fca79df91d22ccd092c8bb4a8 (patch)
tree4a3ccc398199118102bd11501099c9ce46d66e84 /community/gegl
parenta0a82cc2e23c39afb1422c91cd361a2c4396ad77 (diff)
downloadaports-9f33a51efabc9d3fca79df91d22ccd092c8bb4a8.tar.bz2
aports-9f33a51efabc9d3fca79df91d22ccd092c8bb4a8.tar.xz
community/gegl: upgrade to 0.4.14
Diffstat (limited to 'community/gegl')
-rw-r--r--community/gegl/APKBUILD8
-rw-r--r--community/gegl/gegl-uclibc.patch22
2 files changed, 4 insertions, 26 deletions
diff --git a/community/gegl/APKBUILD b/community/gegl/APKBUILD
index bcbd0238b5..400089d227 100644
--- a/community/gegl/APKBUILD
+++ b/community/gegl/APKBUILD
@@ -1,16 +1,16 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gegl
-pkgver=0.4.12
+pkgver=0.4.14
pkgrel=0
pkgdesc="Graph based image processing framework"
-url="http://www.gegl.org/"
+url="https://www.gegl.org/"
arch="all"
license="GPL-3.0 LGPL-3.0"
makedepends="babl-dev libpng-dev libjpeg-turbo-dev gtk+-dev librsvg-dev
lua5.1-dev jasper-dev exiv2-dev json-glib-dev"
checkdepends="diffutils"
subpackages="$pkgname-dev $pkgname-lang"
-source="https://ftp.gimp.org/pub/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+source="https://download.gimp.org/pub/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -35,4 +35,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="cacf9f5c34357b3939162d0d4712ee2b47298a3e806b55e275cdf5e23f186d436ea1a840b91b1b72b76d450d94674cca217b7c253cd6b52a7d9505b4ad73fde2 gegl-0.4.12.tar.bz2"
+sha512sums="1fcec83a961c0b9c98487de99d26893f98a5401816fa6d7238af4c645672d0eb0474cdb7251b8ebcd344aff589e8979bee0304b50fcfae9513fdbf8a02068e3b gegl-0.4.14.tar.bz2"
diff --git a/community/gegl/gegl-uclibc.patch b/community/gegl/gegl-uclibc.patch
deleted file mode 100644
index cb93f0fec7..0000000000
--- a/community/gegl/gegl-uclibc.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./gegl/buffer/gegl-buffer.c.orig
-+++ ./gegl/buffer/gegl-buffer.c
-@@ -80,7 +80,7 @@
- /* #define GEGL_BUFFER_DEBUG_ALLOCATIONS to print allocation stack
- * traces for leaked GeglBuffers using GNU C libs backtrace_symbols()
- */
--#ifndef G_OS_WIN32
-+#if !defined(G_OS_WIN32) && !defined(__UCLIBC__)
- #include <execinfo.h>
- #endif
-
-@@ -876,8 +876,8 @@
- gegl_buffer_get_alloc_stack (void)
- {
- char *result = NULL;
--#ifdef G_OS_WIN32
-- result = g_strdup ("backtrack not available on win32\n");
-+#if defined(G_OS_WIN32) || defined(__UCLIBC__)
-+ result = g_strdup ("backtrack not available\n");
- #else
- void *functions[MAX_N_FUNCTIONS];
- int n_functions = 0;