aboutsummaryrefslogtreecommitdiffstats
path: root/community/geoclue
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-08-29 17:23:22 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-08-29 16:03:24 -0300
commit1e0ad10749b46774dbbbe2ad43a8790a544d0d81 (patch)
treeb76696a9d3243644e3cde6e2907c2a59de28995b /community/geoclue
parent5b44bd0b2a8e771a52eb9330a06904997a20438d (diff)
downloadaports-1e0ad10749b46774dbbbe2ad43a8790a544d0d81.tar.bz2
aports-1e0ad10749b46774dbbbe2ad43a8790a544d0d81.tar.xz
community/geoclue: move from testing
Diffstat (limited to 'community/geoclue')
-rw-r--r--community/geoclue/APKBUILD43
-rw-r--r--community/geoclue/geoclue.pre-install9
2 files changed, 52 insertions, 0 deletions
diff --git a/community/geoclue/APKBUILD b/community/geoclue/APKBUILD
new file mode 100644
index 0000000000..27eca672f3
--- /dev/null
+++ b/community/geoclue/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=geoclue
+pkgver=2.5.3
+pkgrel=0
+pkgdesc="dbus geolocation service"
+url="https://www.freedesktop.org/wiki/Software/GeoClue/"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="
+ meson
+ libsoup-dev
+ json-glib-dev
+ modemmanager-dev
+ avahi-dev
+ intltool
+ gobject-introspection-dev
+ libnotify-dev
+ "
+subpackages="$pkgname-dev $pkgname-doc"
+install="$pkgname.pre-install"
+source="https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/$pkgver/geoclue-$pkgver.tar.bz2"
+
+build() {
+ meson \
+ --prefix=/usr \
+ -Ddbus-srv-user=geoclue \
+ -Ddbus-sys-dir=/usr/share/dbus-1/system.d \
+ -Dgtk-doc=false \
+ -Dintrospection=true \
+ build
+ ninja -C build
+}
+
+check() {
+ ninja -C build test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+sha512sums="b4188f1b055f84ce0c58e497896a328d09838073b867598a0ca026c741e4464ae7ee54e53e9f02addd818152dce4a21eb5f83a3245e7ce1a93eec5671d0a9ee9 geoclue-2.5.3.tar.bz2"
diff --git a/community/geoclue/geoclue.pre-install b/community/geoclue/geoclue.pre-install
new file mode 100644
index 0000000000..bfe6320bb6
--- /dev/null
+++ b/community/geoclue/geoclue.pre-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+# Alpine Linux pre-install script for geoclue
+# Copyright 2019 Leo (thinkabit.ukim@gmail.com)
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+addgroup -S geoclue 2>/dev/null
+adduser -S -D -h /var/lib/geoclue -s /sbin/nologin -G geoclue geoclue 2>/dev/null
+
+exit 0