aboutsummaryrefslogtreecommitdiffstats
path: root/community/geth
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-12-31 20:50:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-01-01 12:17:51 +0000
commit75b324535c568f65f5b35b3539a27419fd0af787 (patch)
tree116ac998ff7eb1b358271ca3050e339b5653c590 /community/geth
parenta09eb83bf131ec19924bc89e8d9bff92f79d6511 (diff)
downloadaports-75b324535c568f65f5b35b3539a27419fd0af787.tar.bz2
aports-75b324535c568f65f5b35b3539a27419fd0af787.tar.xz
community/geth: fix ppc64le build break by re-enabling isatty terminal functions
Diffstat (limited to 'community/geth')
-rw-r--r--community/geth/APKBUILD8
-rw-r--r--community/geth/fix-ppc64le-isatty.patch9
2 files changed, 14 insertions, 3 deletions
diff --git a/community/geth/APKBUILD b/community/geth/APKBUILD
index d0409f61b9..e2f580c612 100644
--- a/community/geth/APKBUILD
+++ b/community/geth/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=geth
pkgver=1.8.20
-pkgrel=0
+pkgrel=1
pkgdesc="Official Go implementation of the Ethereum protocol"
url="https://geth.ethereum.org/"
arch="all"
@@ -10,7 +10,8 @@ license="LGPL-3.0"
makedepends="go linux-headers"
checkdepends="fuse"
options="!check"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ethereum/go-ethereum/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ethereum/go-ethereum/archive/v$pkgver.tar.gz
+ fix-ppc64le-isatty.patch"
builddir="$srcdir/go-ethereum-$pkgver"
build() {
@@ -29,4 +30,5 @@ package() {
install -m755 -t "${pkgdir}"/usr/bin build/bin/*
}
-sha512sums="99a414991801f2deed6d40fe8fcd60f35c0bc1b0f54af4427d4e431de111d626855985ae929663dc5c7454a8d224663858d0f7236238d05c78775377b46510ba geth-1.8.20.tar.gz"
+sha512sums="99a414991801f2deed6d40fe8fcd60f35c0bc1b0f54af4427d4e431de111d626855985ae929663dc5c7454a8d224663858d0f7236238d05c78775377b46510ba geth-1.8.20.tar.gz
+7f1d4cf22e1d48baebd28725ee099cb878028980af336b6e92d1f580a24a7d11e8b302e2b1f8c14f5b18b1d01313abe43464d8bef631ca18e5b0d613fe0a10a0 fix-ppc64le-isatty.patch"
diff --git a/community/geth/fix-ppc64le-isatty.patch b/community/geth/fix-ppc64le-isatty.patch
new file mode 100644
index 0000000000..24b90b200e
--- /dev/null
+++ b/community/geth/fix-ppc64le-isatty.patch
@@ -0,0 +1,9 @@
+--- a/vendor/github.com/mattn/go-isatty/isatty_linux.go
++++ b/vendor/github.com/mattn/go-isatty/isatty_linux.go
+@@ -1,5 +1,5 @@
+ // +build linux
+-// +build !appengine,!ppc64,!ppc64le
++// +build !appengine
+
+ package isatty
+